poj-3869 Headshot

Headshot
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 303 Accepted: 159

Description

You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on a cylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun's barrel. When trigger of the gun is pulled, the gun's cylinder rotates, aligning the next chamber with the barrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamber is empty when the hammer strikes it, then there is no shot but just a "click". 
You have found a use for this gun. You are playing Russian Roulette with your friend. Your friend loads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with a gun's barrel, puts the gun to his head and pulls the trigger. You hear "click" and nothing else - the chamber was empty and the gun did not shoot. 
Now it is your turn to put the gun to your head and pull the trigger. You have a choice. You can either pull the trigger right away or you can randomly rotate the gun's cylinder and then pull the trigger. What should you choose to maximize the chances of your survival?

Input

The input file contains a single line with a string of n digits "0" and "1" (2 <= n <= 100). This line of digits represents the pattern of rounds that were loaded into the gun's chambers. "0" represent an empty chamber, "1" represent a loaded one. In this representation, when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for a shot. Since the chambers are actually located on a circle, the first chamber in this string follows the last one. There is at least one "0" in this string.

Output

Write to the output file one of the following words (without quotes): 


"SHOOT" - if pulling the trigger right away makes you less likely to be actually shot in the head with the bullet (more likely that the chamber will be empty). 
"ROTATE" - if randomly rotating the cylinder before pulling the trigger makes you less likely to be actually shot in the head with the bullet (more likely that the chamber will be empty). 
"EQUAL" - if both of the above choices are equal in terms of probability of being shot. 

Sample Input

Sample Input #1:
0011

Sample Input #2:
0111

Sample Input #3:
000111

Sample Output

Sample Output #1:
EQUAL

Sample Output #2:
ROTATE

Sample Output #3:
SHOOT

Source

题意 :两个熊孩子玩俄罗斯赌轮,先往左轮手枪里放入子弹,然后同伴随机转动,之后开枪。没死,这时到你,你有两种选择,一种是直接开枪,另一种是随机转动一次,再开枪。要求你选择这两种中间的一种,确保你被枪打死的几率最小。如果相等输出EQUAL。
分析:首先让我吐槽一下这个输入输出的格式,只需要管0111 0011 EQUAL等就行,前面的那些直接无视。害的我wa了好几次。
好吧,言归正传,这里的"0"有两种,一种是后面还跟了一个“0”,这种情况就可以开枪了。另一种是后面跟的是“1”,这种情况就转手枪。我们先把所有的0统计出来b。再把01的0的个数统计出来 a。这样b/sum(总数)--a/b  我们就得到了一个概率差。
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
	char  sa[10000];
	int len,i;
	double t,a,b;
	while(~scanf("%s",sa))
	{
		a=b=0;
		len=strlen(sa);
		for(i=0;i<len-1;i++)
		{
			if(sa[i]=='0'&&sa[i+1]=='0')
				a++;
			if(sa[i]=='0')
				b++;
		}
		if(sa[len-1]=='0')
		{
			b++;
			if(sa[0]=='0')
				a++;
		}
		t=b/len-a/b;
		if(t>0.000001)
			puts("ROTATE\n\n");
		else
			if(t<-0.000001)
				puts("SHOOT\n\n");
			else
				puts("EQUAL\n\n");
		
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值