[母函数]HDU 1709 The Balance

传送门:The Balance

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5048    Accepted Submission(s): 2015


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

Source

解题报告:

此题为母函数。记得可以用少的减去多的来合成一个数。

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int c1[10005],c2[10005];
int a[105],ans[10005];
int main(){
	int i,j,n,sum;
	while(scanf("%d",&n)==1){
		sum=0;
		for(i=1;i<=n;i++){
			scanf("%d",&a[i]);
			sum=sum+a[i];
		}
		for(i=0;i<=sum;i++){
			c1[i]=0;
			c2[i]=0;
		}
		c1[0]=1;
		for(i=1;i<=n;i++){
			for(j=0;j+a[i]<=sum;j++){
				if(c1[j]){
					c2[j]=1;
					c2[j+a[i]]=1;
					c2[abs(j-a[i])]=1;
				}
			}
			for(j=0;j<=sum;j++){
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		int num=0;
		for(i=1;i<=sum;i++)
			if(c1[i]==0)
				ans[num++]=i;
		if(num==0){
			printf("0\n");
			continue;
		}
		printf("%d\n",num);
		for(i=0;i<num-1;i++)
			printf("%d ",ans[i]);
		printf("%d\n",ans[num-1]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值