Wampserver Apache服务无法启动解决方案

1、前言

       最近博主中途加入一个项目,负责人大佬是用 PHP 写的后台,奈何我没用过 PHP,就写前端页面去了。现在到了前后台连接交互的阶段,于是也打算配置环境,将前后台打通,结果在安装 Wampserver 中出现了很多奇奇怪怪的错误,公司电脑和实验室电脑也分别出现图标为橙色的状态和报错,在网上也查了半天,终于都解决了,还好没放弃。

       版本是:wampserver2.5-Apache-2.4.9-Mysql-5.6.17-php5.5.12-64b

2、问题描述及解决

(1)图标显示为红色,错误显示:服务在此时无法接受控制信息

        公司电脑(win7)上一开始安装后是可以正常启动的,安全的用了几天后,某天上班发现启动 Wampserver 图标为红色,点击 online 出现错误:服务在此时无法接受控制信息,测试端口80显示没有被占用,不是端口问题,于是以为缓存爆炸了,就卸载+重装+重启(此处立flag,一开始安装在 F:/Wamp ,重装那时换了个文件夹 F:/new/Wamp),还是没有用。。突然想起上周安装了mysql,不知道会不会跟这个冲突了,这边就上不了,于是解决如下:

       打开我的电脑  --> 右击管理 -->  服务和应用服务   --> 服务  -->  mysql  ,果然看见正在运行,于是停止,并改为手动。重启服务,Restart all service 后变为绿色,则成功。。。然而并没有,但从红色变为了橙色,错误显示:服务无法启动。。。

       试遍了所有方案,甚至根据网上说的,运行 -> RegEdit -> Hkey_local_Machine -> System -> CurrentControlSet -> Services ->Http -> start 数值改为0,还是无果,差点要放弃了。。然后突然灵光一闪,会不会是我卸载不干净,有些设置还默认我之前那个文件路径,于是我又卸载+重装在 F:/Wamp 这个文件夹里面,重启,秒变绿啊哈哈。

(2)图标显示为橙色,错误显示:服务无法启动

       首先,用 Wampserver 自带的检测端口80是否被占用:点击图标  -->  Apache  -->   Service  -->   Test Port 80

       假如显示 port 80 is not used,证明端口没有被占用,证明不是端口问题,跳过看(2);
       假如显示 port 80 is used by ***,证明端口被 *** 所占用。本人实验室电脑 (win10) 显示的是被 Microsoft IIS/10.0 占用。两个解决方案,一种是像网上其他解决方案一样,点击W图标打开 Apache   httpd.conf,查找‘80’,将所有端口80改为其他没有被占用的端口,例如8080。博主曾试过几次改端口,都不怎么work,估计姿势不对,遂放弃。
       另一个方法是: 打开文件夹 --> 此电脑(win7对应中我的电脑)  --> 右击管理 -->  服务和应用服务   --> 服务  -->  World Wide Web 发布服务  -->  停止,并改为手动。重启服务, Restart all service  后变为绿色,则成功。若仍为橙色,Test Port 80,且显示端口没有被占用。。请继续看下去。

(3)端口没有被占用,但图标仍显示为橙色,错误显示:服务无法启动

        不是端口问题,不是mysql问题,仍显示橙色,试遍了所有方法都不行,而且这是我第一次在实验室的电脑安装,不会存在卸载不干净的问题。。很抓狂有没有。。。最后想起(1)中那个骚操作,因为我安装在D:/SOFEWARE/wamp 中,想着会不会是必须要在硬盘根目录下,于是卸载了重装,url:E:/wamp 。开启,秒绿(微笑脸)。

3、总结

        总的来说:
        A、查端口是否被占用,被占用的话改端口或关掉占用端口的服务;
        B、看曾经是否安装过的mysql、Apache 等已经在运行,把之前的服务停止,再重启wampserver;
        C、看看之前安装过有没有卸载不干净,都没有的话,试试骚操作:在硬盘目录下安装(不保证真的work,玄学)。
        别看这个很简单的一键式安装,报错了也是挺让人抓狂的~ 还是要稍安勿躁,一步步排除问题,最终得到解决。。
    



已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页