安装wampserver后apache不能启动的问题

    在配置apache的php运行环境时,发现在httpd.conf里开启LoadModule php7_module D:/upset/php/php-7.1.29-nts-Win32-VC14-x64/php7apache2_4.dll时找不到该文件,于是在朋友的提醒下直接安装wampservesr,直接找到里面的php7apache2_4.dll拷贝粘贴到apache目录下面,以为万事顺顺,结果却发现wamp可以运行,而apache一直运行不起来。
	当然有事没事还是得找自家娘娘,经过一番探索发现无果,就想着会不会是复制的文件的问题,于是在apache目录下检测apache是哪里运行出错,在cmd里测试 httpd -t  后,问题出来了
	![在这里插入图片描述](https://img-blog.csdnimg.cn/201905190841550.png)
	![在这里插入图片描述](https://img-blog.csdnimg.cn/20190519084229706.png)
	...虽然不懂上面的提示是什么意思,于是就重新下载了个自带有php7apache2_4.dll的php-7.1.29-Win32-VC14-x64,果不其然重新安装可以解决百分之99的问题。

		最后了解了这个php环境里 vc版本和nts版本的区别,这里不抄袭,就给搬运过来
		https://blog.csdn.net/bernin/article/details/81427643
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页