算法训练 安慰奶牛
时间限制:1.0s 内存限制:256.0MB
问题描述
Farmer John变得非常懒,他不想再继续维护供奶牛之间供通行的道路。道路被用来连接N个牧场,牧场被连续地编号为1到N。每一个牧场都是一个奶牛的家。FJ计划除去P条道路中尽可能多的道路,但是还要保持牧场之间 的连通性。你首先要决定那些道路是需要保留的N-1条道路。第j条双向道路连接了牧场Sj和Ej(1 <= Sj <= N; 1 <= Ej <= N; Sj != Ej),而且走完它需要Lj的时间。没有两个牧场是被一条以上的道路所连接。奶牛们非常伤心,因为她们的交通系统被削减了。你需要到每一个奶牛的住处去安慰她们。每次你到达第i个牧场的时候(即使你已经到过),你必须花去Ci的时间和奶牛交谈。你每个晚上都会在同一个牧场(这是供你选择的)过夜,直到奶牛们都从悲伤中缓过神来。在早上 起来和晚上回去睡觉的时候,你都需要和在你睡觉的牧场的奶牛交谈一次。这样你才能完成你的 交谈任务。假设Farmer John采纳了你的建议,请计算出使所有奶牛都被安慰的最少时间。
输入格式
第1行包含两个整数N和P。
接下来N行,每行包含一个整数Ci。
接下来P行,每行包含三个整数Sj, Ej和Lj。
输出格式
输出一个整数, 所需要的总时间(包含和在你所在的牧场的奶牛的两次谈话时间)。
样例输入
5 7
10
10
20
6
30
1 2 5
2 3 5
2 4 12
3 4 17
2 5 15
3 5 6
10
10
20
6
30
1 2 5
2 3 5
2 4 12
3 4 17
2 5 15
3 5 6
样例输出
176
数据规模与约定
5 <= N <= 10000,N-1 <= P <= 100000,0 <= Lj <= 1000,1 <= Ci <= 1,000。
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.Comparator;
public class Main {
/**
* @param args
*/
static Node[] tree;
static int N;
static int P;
static int[] C;
static int[] father;
public static void main(String[] args) throws IOException {
// TODO Auto-generated method stub
BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
String s1[] = bf.readLine().split(" ");
N = Integer.parseInt(s1[0]);
P = Integer.parseInt(s1[1]);
C = new int[N + 1];
tree = new Node[P];
C[1] = Integer.parseInt(bf.readLine());
int min;
min = C[1];
for (int i = 2; i <= N; i++) {
C[i] = Integer.parseInt(bf.readLine());
if (C[i] < min)
min = C[i];
}
for (int i = 0; i < P; i++) {
String s2[] = bf.readLine().split(" ");
tree[i] = new Node();
tree[i].a = Integer.parseInt(s2[0]);
tree[i].b = Integer.parseInt(s2[1]);
tree[i].c = 2 * Integer.parseInt(s2[2]) + C[tree[i].a]
+ C[tree[i].b];
}
Arrays.sort(tree, new Comparator<Node>() {
@Override
public int compare(Node arg0, Node arg1) {
// TODO Auto-generated method stub
return arg0.c - arg1.c;
}
});
int sum = krcuskal();
System.out.println(sum + min);
}
private static int krcuskal() {
// TODO Auto-generated method stub
int sum = 0;
int count = 0;
father = new int[N + 1];
for (int i = 1; i < N + 1; i++) {
father[i] = i;
}
for (int i = 0; i < P; i++) {
int a = Find(tree[i].a);
int b = Find(tree[i].b);
if (a == b)
continue;
father[b] = a;
sum += tree[i].c;
count++;
if (count >= N - 1)
break;
}
return sum;
}
private static int Find(int x) {
// TODO Auto-generated method stub
int r = x;
while (r != father[r])
r = father[r];
while (x != r) {
int temp = father[x];
father[x] = r;
x = temp;
}
return r;
}
}
class Node {
int a;
int b;
int c;
}