hdu-1518-Square

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5905    Accepted Submission(s): 1883


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 


 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 


 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 


 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 


 

Sample Output
  
  
yes no yes
 


 

Source
 


 

Recommend
LL
 


 

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;


public class Main {

	/**
	 * @param args
	 */
	static Integer[] gun;
	static boolean[] mark;
	static int edge=0;
	static boolean flag;
	static int n;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input=new Scanner(System.in);
		int m=input.nextInt();
		while(m-->0){
			flag=false;
			edge=0;
			int count=0;
			n=input.nextInt();
			gun=new Integer[n];
			mark=new boolean[n];
			for(int i=0;i<n;i++){
				gun[i]=input.nextInt();
				count+=gun[i];
			}
			edge=count>>2;
			Arrays.sort(gun,new Comparator<Integer>(){

				@Override
				public int compare(Integer arg0, Integer arg1) {
					// TODO Auto-generated method stub
					return arg1-arg0;
				}
				
			});
			if(count%4==0&&gun[0]<=edge){
				dfs(0,0,0);
				if(flag==true)
					System.out.println("yes");
				else
					System.out.println("no");
			}
			else
				System.out.println("no");
	
		}//while

	}
	private static void dfs(int cur, int curlen, int numberOFedge) {
		// TODO Auto-generated method stub
		if(flag==true)
			return;
		if(numberOFedge==3){
			flag=true;
			return;
		}
		if(curlen==edge){
			dfs(numberOFedge+1,0,numberOFedge+1);
		}
		for(int i=cur;i<n;i++){
			if(mark[i]==false){
				if(curlen+gun[i]<=edge){
					mark[i]=true;
					dfs(i+1,curlen+gun[i],numberOFedge);
					mark[i]=false;
				}
			}
		}
			
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值