poj-1915-Knight Moves(广搜)

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19683 Accepted: 9084

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany
import java.util.ArrayDeque;
import java.util.Queue;
import java.util.Scanner;

public class Main {

	/**
	 * @param args
	 */
	static Queue<Status> queue=new ArrayDeque<Status>();
	static boolean[][] mark;
	static int end_x;
	static int end_y;
	static int[][] dir={{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};
	static int n;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input=new Scanner(System.in);
		int m=input.nextInt();
		while(m-->0){
			queue.clear();
			n=input.nextInt();
			mark=new boolean[n][n];
			int start_x=input.nextInt();
			int start_y=input.nextInt();
			end_x=input.nextInt();
			end_y=input.nextInt();
			Status start=new Status();
			start.setX(start_x);
			start.setY(start_y);
			start.setStep(0);
			queue.add(start);
			int result=bfs(queue);
		    System.out.println(result);
		}
	}//main
	private static int bfs(Queue<Status> queue) {
		// TODO Auto-generated method stub
		while(!queue.isEmpty()){
			Status s=queue.poll();
			if(s.getX()==end_x && s.getY()==end_y)
				return s.step;
			for(int i=0;i<dir.length;++i){
				int x=s.getX()+dir[i][0];
				int y=s.getY()+dir[i][1];
				if(x<0 || x>=n || y<0 || y>=n)
					continue;
				Status status=new Status();
				status.setX(x);
				status.setY(y);
				status.setStep(s.step+1);
				if(mark[x][y]==false){
					queue.add(status);
					mark[x][y]=true;
				}
			}
		}
		return 0;
	}
	
}
class Status{
	int x;
	int y;
	int step;
	public int getX() {
		return x;
	}
	public void setX(int x) {
		this.x = x;
	}
	public int getY() {
		return y;
	}
	public void setY(int y) {
		this.y = y;
	}
	public int getStep() {
		return step;
	}
	public void setStep(int step) {
		this.step = step;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值