poj-3468-A Simple Problem with Integers(线段树)

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 47608 Accepted: 13992
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

import java.util.Scanner;

public class Main {

	/**
	 * @param args
	 */
	static int[] w;
	static Node[] tree;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
        Scanner input=new Scanner(System.in);
        while(input.hasNext()){
        	int N=input.nextInt();
        	int Q=input.nextInt();
        	w=new int[N+1];
        	tree=new Node[N*3];
        	for(int i=1;i<N+1;i++)
        		w[i]=input.nextInt();
        	Build(1,1,N);//先建树,第一个1是数组坐标,第二个1和N是区间范围
        	for(int i=0;i<Q;i++){
        		String s=input.next();
                if(s.charAt(0)=='Q'){
                	int a=input.nextInt();
                	int b=input.nextInt();
                	long result=Query(1,a,b);
                	System.out.println(result);
                }
                else{
                	int a=input.nextInt();
                	int b=input.nextInt();
                	int c=input.nextInt();
                	Updata(1,a,b,c);
                }
        	}
        }
	}
	private static void Updata(int p, int left, int right, int add) {
		// TODO Auto-generated method stub
		if(tree[p].left==left && tree[p].right==right){
			tree[p].add+=add;
			return;
		}
		tree[p].value += (right-left+1)*add;
		int v=p<<1;
		int mid=(tree[p].left+tree[p].right)>>1;
		if(right<=mid)
			Updata(v,left,right,add);
		else if(left>=mid+1)
			Updata(v+1,left,right,add);
		else{
			Updata(v,left,mid,add);
		    Updata(v+1,mid+1,right,add);
		}
	}
	private static long Query(int p, int left, int right) {
		// TODO Auto-generated method stub
		int len=tree[p].right-tree[p].left+1;
		int v=p<<1;
		if(tree[p].left==left && tree[p].right==right)
			return tree[p].value+tree[p].add*len;
		else{
			tree[v].add+=tree[p].add;
			tree[v+1].add+=tree[p].add;
			tree[p].value+=len*tree[p].add;
			tree[p].add=0;
		}
		int mid=(tree[p].left+tree[p].right)>>1;
		if(right<=mid)
			return Query(v,left,right);
		else if(left>=mid+1)
			return Query(v+1,left,right);
		else
			return Query(v,left,mid)+Query(v+1,mid+1,right);
	}
	private static void Build(int p, int left, int right) {
		// TODO Auto-generated method stub
		tree[p]=new Node();
		tree[p].left=left;
		tree[p].right=right;
		tree[p].add=0;
		if(left==right){
			tree[p].value=w[left];
			return;
		}
		int mid=(left+right)>>1;
        int v=p<<1;
        Build(v,left,mid);
        Build(v+1,mid+1,right);
        tree[p].value=tree[v].value+tree[v+1].value;
	}
}
class Node{
	int left;
	int right;
	long value;
	long add;//增量
	public int getLeft() {
		return left;
	}
	public void setLeft(int left) {
		this.left = left;
	}
	public int getRight() {
		return right;
	}
	public void setRight(int right) {
		this.right = right;
	}
	public long getValue() {
		return value;
	}
	public void setValue(long value) {
		this.value = value;
	}
	public long getAdd() {
		return add;
	}
	public void setAdd(long add) {
		this.add = add;
	}
	Node(){
		
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值