hdu 4715 Difference Between Primes (打表 枚举)

Difference Between Primes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 528    Accepted Submission(s): 150


Problem Description
All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture, you are asked to write a program.
 

Input
The first line of input is a number nidentified the count of test cases(n<10^5). There is a even number xat the next nlines. The absolute value of xis not greater than 10^6.
 

Output
For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output 'FAIL'.
 

Sample Input
  
  
3 6 10 20
 

Sample Output
  
  
11 5 13 3 23 3
 

Source


思路:
打个素数表,然后枚举b,判断a就够了。
ps:汗,开始以为xat为正数,一直WA,原来题目说的是绝对值。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 10000005
using namespace std;

int n,m,cxx,ans;
bool vis[maxn];
int prime[664580];

void sieve(int nn)
{
    int i,j,mm;
    mm=int(sqrt(nn+0.5));
    memset(vis,0,sizeof(vis));
    for(i=2;i<=mm;i++)
    {
        if(!vis[i])
        {
            for(j=i*i;j<=nn;j+=i)
            {
                vis[j]=1;
            }
        }
    }
}
int get_prime(int nn)
{
    int i,c=0;
    sieve(nn);
    for(i=2;i<=nn;i++)
    {
        if(!vis[i]) prime[c++]=i;
    }
    return c;
}
bool isprime(int x)
{
    int i,j,t;
    t=sqrt(x+0.5);
    for(i=2;i<=t;i++)
    {
        if(x%i==0) return false ;
    }
    return true ;
}
int main()
{
    int i,j,t,a,b,flag,sgn;
    cxx=get_prime(10000000);  // 664579
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        flag=0;
        if(n>=0) sgn=1;
        else sgn=0,n=-n;
        for(i=0;i<cxx;i++)
        {
            b=prime[i];
            a=b+n;
            if(isprime(a))
            {
                flag=1;
                if(sgn) printf("%d %d\n",a,b);
                else printf("%d %d\n",b,a);
                break ;
            }
        }
        if(!flag) printf("FAIL\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值