uva 709 &poj 1093 - Formatting Text (dp之小白告一段落)

709 - Formatting Text


Writings e-mails is fun, but, unfortunately, they do not look very nice, mainly because not all lines have the same lengths. In this problem, your task is to write an e-mail formatting program which reformats a paragraph of an e-mail (e.g. by inserting spaces) so that, afterwards, all lines have the same length (even the last one of each paragraph).

The easiest way to perform this task would be to insert more spaces between the words in lines which are too short. But this is not the best way. Consider the following example:

****************************
This is the example you are
actually considering.

Let us assume that we want to get lines as long as the row of stars. Then, by simply inserting spaces, we would get

****************************
This is the example you  are
actually        considering.

But this looks rather odd because of the big gap in the second line. By moving the word ``are'' from the first to the second line, we get a better result:

****************************
This  is  the  example   you
are  actually   considering.

Of course, this has to be formalized. To do this, we assign a badness to each gap between words. The badness assigned to a gap of n spaces is (n - 1)2. The goal of the program is to minimize the sum of all badnesses. For example, the badness of the first example is 1 + 72 = 50 whereas the badness of the second one is only 1 + 1 + 1 + 4 + 1 + 4 = 12.

In the output, every line has to start and to end with a word. (I.e. there cannot be a gap at the beginning or the end of a line.) The only exception to this is the following:

If a line contains only one word this word shall be put at the beginning of the line, and a badness of 500 is assigned to this line if it is shorter than it should be. (Of course, in this case, the length of the line is simply the length of the word.)

Input 

The input file contains a text consisting of several paragraphs. Each paragraph is preceded by a line containing a single integer n, the desired width of the paragraph ( $1 \le n \le 80$).

Paragraphs consist of one or more lines which contain one or more words each. Words consist of characters with ASCII codes between 33 and 126, inclusive, and are separated by spaces (possibly more than one). No word will be longer than the desired width of the paragraph. The total length of all words of one paragraph will not be more than 10000 characters.

Each paragraph is terminated by exactly one blank line. There is no limit on the number of paragraphs in the input file.

The input file will be terminated by a paragraph description starting withn=0. This paragraph should not be processed.

Output 

Output the same text, formatted in the way described above (processing each paragraph separately).

If there are several ways to format a paragraph with the same badness, use the following algorithm to choose which one to output: Let A and B be two solutions. Find the first gap which has not the same length in A and B. Donot output the solution in which this gap is bigger.

Output a blank line after each paragraph.

Sample Input 

28
This is the example you are
actually considering.

25
Writing e-mails is fun, and with this program,
they even look nice.

0

Sample Output 

This  is  the  example   you
are  actually   considering.

Writing e-mails  is  fun,
and  with  this  program,
they  even   look   nice.


题意:(贴别人的)

给出n,给出一篇文章,有若干个单词,以空行结束,现在要将文章排序使得文章的badness 越小。
badness 的计算方法,如果一行只有一个单词的话,若单词的长度小于n,则badness 增加500,若等于n则为0。
若一行有多个单词,每两个单词之间的badness = (c - 1) ^ 2 (c为两个单词的空格数),要求,每行控制长度在n,并且前一个单词顶头,后一个单词顶尾(一个单次的情况除外)


思路:

dp[i][j]-第i个单词放在位置j时(不管哪行)最小badness。

那么 dp[i][j]=dp[i+1][j+k]+产生的badness 

细心判断k的范围,用记忆化搜索实现dp,考虑题目的各种需要满足的条件才能AC。

用next[i][j]数组纪录路径输出,注意一行只有1个单词时末尾不要有空格。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,cnt,tot,flag;
int num[10005],sum[10005];
vector<string>v;
char s[10005];
int dp[10001][85],next[10001][85];

int sqr(int x)
{
    return x*x;
}
int dfs(int x,int y)
{
    if(y+v[x].length()-1>n) return INF;
    if(dp[x][y]!=INF) return dp[x][y];
    if(x==m)
    {
        if(y+v[x].length()-1==n) return 0;
        else
        {
            if(y==1) return 500;
            return INF;
        }
    }
    int i,j,t,best=INF;
    for(i=y+v[x].length()+1;i<=n-v[x+1].length()+1;i++)
    {
        t=dfs(x+1,i)+sqr(i-y-v[x].length()-1);
        if(best>t)
        {
            best=t;
            next[x][y]=i;
        }
    }
    if(y==1)
    {
        t=dfs(x+1,1)+500;
        if(best>t)
        {
            best=t;
            next[x][y]=1;
        }
    }
    if(y+v[x].length()-1==n)
    {
        t=dfs(x+1,1)+0;
        if(best>t)
        {
            best=t;
            next[x][y]=1;
        }
    }
    dp[x][y]=best;
    return best;
}
void output(int x,int y)
{
    cout<<v[x];
    int t=y+v[x].length();
    if(t==n+1||next[x][y]==1||x==m)
    {
        printf("\n");
    }
    else
    {
        for(int i=t;i<next[x][y];i++)
        {
            printf(" ");
        }
    }
//    printf("x:%d y:%d\n",x,y);
    if(x==m) return ;
    output(x+1,next[x][y]);
}
int main()
{
    int i,j,t;
    while(scanf("%d",&n),n)
    {
        gets(s);
        string xx;
        v.clear();
        v.push_back("yj");
        cnt=0;
        sum[0]=0;
        while(gets(s))
        {
            if(s[0]=='\0') break ;
            xx="";
            for(i=0; ;i++)
            {
                if(s[i]!=' '&&s[i]!='\0')
                {
                    xx+=s[i];
                }
                else
                {
                    if(xx.length()>0)
                    {
                        v.push_back(xx);
                    }
                    xx="";
                    if(s[i]=='\0') break ;
                }
            }
        }
        m=v.size()-1;
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                dp[i][j]=INF;
            }
        }
        ans=dfs(1,1);
        output(1,1);
        cout<<endl;
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值