poj 2870 Light Up (dfs+强剪枝)

Light Up
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 737 Accepted: 285

Description

Light Up is a puzzle set in a rectangular board divided in smaller squares. Some squares in the board are ``empty'' (white squares the figure below), some squares are ``barriers'' (dark squares in the figure below). A barrier square may have an integer number i associated to it (0 <= i <= 4). 

 
Figure 2: (a) Puzzle with 6 rows, 7 columns and 7 barriers; (b) a solution to the puzzle.


In this puzzle the goal is to ``light up'' all the empty squares by placing lamps in some of them (lamps are depicted as circles in the figure). Each lamp illuminates the square it is on, plus all squares in line with it, horizontally or vertically, up to a barrier square or the board end. 

A winning configuration satisfies the following conditions:
  • all empty squares must be lit;
  • no lamp may be lit by another lamp;
  • all numbered barrier squares must have exactly that number of lamps adjacent to them (in the four squares above, below, and to the side);
  • non-numbered barrier squares may have any number of lamps adjacent to them.


You must write a program to determine the smallest number of lamps that are needed to reach a winning configuration.

Input

The input contains several test cases. The first line of a test case contains two integers N, M indicating respectively the number of rows and the number of columns of the board (1 <= N <= 7, 1 <= M <= 7). The second line contains one integer B indicating the number of barrier squares (0 <= B <= N × M). Each of the next B lines describe a barrier, containing three integers R, C and K, representing respectively the row number (1 <= R <= N), the column number (1 <= C <= M) and the barrier number (-1 <= K <= 4); K = -1 means the barrier is unnumbered. The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing either an integer indicating the smallest number of lamps needed to reach a winning configuration, in case such a configuration exists, or the words `No solution'.

Sample Input

2 2
0
2 2
1
2 2 1
6 7
7
2 3 -1
3 3 0
4 2 1
5 4 3
5 6 2
1 7 -1
6 5 -1
0 0

Sample Output

2
No solution
8
 
 
思路:dfs+剪枝  地图不大 将所有情况搜索都搜一遍 最后判断是否满足条件 然后更新ans
不过这题剪枝还是必须的  具体代码解释的详细 这里不说了
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 10
using namespace std;

int n,m,b,ans;
int mp[maxn][maxn];
int vis[maxn][maxn];
int jmp[maxn][maxn];
int light[maxn][maxn];
int dx[]= {-1,1,0,0};
int dy[]= {0,0,-1,1};

void showvis()             // 中间输出  方便debug
{
    int i,j;
    printf("\n");
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=m; j++)
        {
            printf("%d",vis[i][j]);
        }
        printf("\n");
    }
}
bool isok(int tx,int ty)  // 判断能否放灯
{
    int i,j;
    for(i=tx-1; i>=1; i--)
    {
        if(vis[i][ty]) return false;
        else if(mp[i][ty]) break ;
    }
    for(i=tx+1; i<=n; i++)
    {
        if(vis[i][ty]) return false;
        else if(mp[i][ty]) break ;
    }
    for(j=ty-1; j>=1; j--)
    {
        if(vis[tx][j]) return false;
        else if(mp[tx][j]) break ;
    }
    for(j=ty+1; j<=m; j++)
    {
        if(vis[tx][j]) return false;
        else if(mp[tx][j]) break ;
    }
    return true ;
}
void expand(int tx,int ty)     // 扩展  将灯能照亮的地方都点亮
{
    int i,j;
    for(i=tx; i>=1; i--)
    {
        if(mp[i][ty]) break ;
        else jmp[i][ty]=1;
    }
    for(i=tx; i<=n; i++)
    {
        if(mp[i][ty]) break ;
        else jmp[i][ty]=1;
    }
    for(j=ty-1; j>=1; j--)
    {
        if(mp[tx][j]) break ;
        else jmp[tx][j]=1;
    }
    for(j=ty+1; j<=m; j++)
    {
        if(mp[tx][j]) break ;
        else jmp[tx][j]=1;
    }
}
bool judge()                 // 判断搜出来的情况是否合理
{
    int i,j,k,cnt;
    memset(jmp,0,sizeof(jmp));
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=m; j++)
        {
            if(vis[i][j]) expand(i,j);        // 将标记了的都扩展
        }
    }
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=m; j++)
        {
            if(!mp[i][j]&&!jmp[i][j]) return false ;      // 如果还有一个位置没亮的话就不行
        }
    }
//    showvis();
    for(i=1; i<=n; i++)              // 检测墙的周围灯的个数是否满足条件
    {
        for(j=1; j<=m; j++)
        {
            if(light[i][j]==-1) continue ;
            cnt=0;
            for(k=0; k<4; k++)
            {
                if(vis[i+dx[k]][j+dy[k]]) cnt++;
            }
            if(cnt!=light[i][j]) return false ;
        }
    }
    return true ;
}
bool midcut(int tx,int ty)        // 中间剪枝  如果有墙的周围不满足条件了 就 return false
{
    int i,j,k,cnt;
    for(i=1; i<=tx-2; i++)
    {
        for(j=1; j<=m; j++)
        {
            if(light[i][j]==-1) continue ;
            cnt=0;
            for(k=0; k<4; k++)
            {
                if(vis[i+dx[k]][j+dy[k]]) cnt++;
            }
            if(cnt!=light[i][j]) return false ;
        }
    }
    i=tx-1;
    for(j=1; j<=ty-1; j++)
    {
        if(light[i][j]==-1) continue ;
        cnt=0;
        for(k=0; k<4; k++)
        {
            if(vis[i+dx[k]][j+dy[k]]) cnt++;
        }
        if(cnt!=light[i][j]) return false ;
    }
    return true ;
}
bool goodcut(int tx,int ty)     // 强剪枝   如果所搜点为墙 且其上方为黑暗的,则剪枝!
{
    int i,j,k,cnt;
    memset(jmp,0,sizeof(jmp));
    for(i=1; i<=tx-1; i++)
    {
        for(j=1; j<=m; j++)
        {
            if(vis[i][j]) expand(i,j);
        }
    }
    if(!jmp[tx-1][ty]) return false;
    return true ;
}
void dfs(int nx,int ny,int cxx)
{
    if(ans<=cxx) return ;
    if(!midcut(nx,ny)) return ;   // 中间剪枝可以不要 其实在poj上不要还快一些 因为他的数据没有偏重这一点
    if(nx>=n&&ny>m||nx>n)
    {
        if(judge())               // 全部搜完后判断情况是否合理
        {
            if(ans>cxx) ans=cxx;  // 更新ans
        }
        return ;
    }
    if(ny>m) dfs(nx+1,1,cxx);
    else if(mp[nx][ny])
    {
        if(nx>=2&&!mp[nx-1][ny]&&!goodcut(nx,ny)) return ;   // 注意前面的条件
        dfs(nx,ny+1,cxx);
    }
    else
    {
        dfs(nx,ny+1,cxx);
        if(!vis[nx][ny]&&isok(nx,ny))
        {
            vis[nx][ny]=1;
            dfs(nx,ny+1,cxx+1);
            vis[nx][ny]=0;
        }
    }
}
int main()
{
    int i,j,r,c,k;
    while(scanf("%d%d",&n,&m),n||m)
    {
        scanf("%d",&b);
        memset(mp,0,sizeof(mp));
        memset(light,-1,sizeof(light));
        for(i=1; i<=b; i++)
        {
            scanf("%d%d%d",&r,&c,&k);
            mp[r][c]=1;
            light[r][c]=k;
        }
        memset(vis,0,sizeof(vis));
        ans=1000000;
        dfs(1,1,0);
        if(ans<1000000) printf("%d\n",ans);
        else printf("No solution\n");
    }
    return 0;
}
/*
ps:如果能够过这组数据就不会TLE了
7 7
24
1 2 -1
1 4 -1
1 6 -1
2 1 -1
2 3 -1
2 5 -1
2 7 -1
3 2 -1
3 4 -1
3 6 -1
4 1 -1
4 3 -1
4 5 -1
4 7 -1
5 2 -1
5 4 -1
5 6 -1
6 1 -1
6 3 -1
6 5 -1
6 7 -1
7 2 -1
7 4 -1
7 6 -1

ans: 25
*/


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值