poj 1094 Sorting It All Out (拓扑排序)

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23946 Accepted: 8280

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source


题意:给你一些大写字母间的偏序关系,然后让你判断能否唯一确定它们之间的关系,或者所给关系是矛盾的,或者到最后也不能确定它们之间的关系。

拓扑排序的结果一般分为三种情况:1、可以判断 2、有环出现了矛盾 3、条件不足,不能判断.

这道题是要判断在处理第几个关系时出现前两种情况   若关系全部处理完还不出现  则为情况三

故每输入一个关系就要拓扑排序一次


感想:这题WA了我一个早上+半个下午呀!发火   一个简单的拓扑排序我都WA成这样了  感觉自己真实弱爆了 


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#define maxn 30
using namespace std;

int n,m,ans,x;
bool vis[maxn],visnum[maxn];
char s[maxn],y[maxn];
int num[maxn],edge[maxn][maxn],tmp[maxn];
stack<int>sta;

int tpsort(int kk)                 // 每次最多循环出现过的字母的个数次
{
    int i,j,nx,cnt=-1,cxx=-1,si,flag;
    char c;
    memcpy(tmp,num,sizeof(num));
    memset(vis,0,sizeof(vis));
    flag=1;
    while(!sta.empty()) sta.pop();
    while(1)
    {
        cxx++;
        if(cxx>=n)
        {
            if(!flag) return 3;
            y[++cnt]='\0';
            return 1;
        }
        if(cxx>=kk) return 3;
        for(i=0; i<n; i++)
        {
            if(tmp[i]==0&&!vis[i])
            {
                vis[i]=1;
                sta.push(i);
            }
        }
        if(sta.empty())
        {
            return 2;
        }
        else
        {
            si=sta.size();
            if(si>1) flag=0;    // !这里只能标记 不能直接return 3 因为到后面时可能出现矛盾的情况
            nx=sta.top();
            c=nx+'A';
            y[++cnt]=c;
            sta.pop();
            for(i=0; i<n; i++)
            {
                if(edge[nx][i]&&tmp[i]>0)
                {
                    tmp[i]--;
                }
            }
        }
    }
}
int main()
{
    int i,j,t,flag,k;
    while(scanf("%d%d",&n,&m),n||m)
    {
        flag=k=0;
        memset(edge,0,sizeof(edge));
        memset(num,0,sizeof(num));
        memset(visnum,0,sizeof(visnum));
        for(i=1; i<=m; i++)
        {
            scanf("%s",s);
            if(!edge[s[0]-'A'][s[2]-'A'])
            {
                num[s[2]-'A']++;
                if(!visnum[s[0]-'A'])
                {
                    k++;
                    visnum[s[0]-'A']=1;
                }
                if(!visnum[s[2]-'A'])
                {
                    k++;
                    visnum[s[2]-'A']=1;
                }
                edge[s[0]-'A'][s[2]-'A']=1;
                t=tpsort(k);
                if(t==1||t==2)
                {
                    flag=1;
                    for(j=i+1; j<=m; j++)
                    {
                        scanf("%s",s);
                    }
                    if(t==1)
                    {
                        printf("Sorted sequence determined after %d relations: %s.\n",i,y);
                    }
                    else if(t==2)
                    {
                        printf("Inconsistency found after %d relations.\n",i);
                    }
                    break ;
                }
            }
        }
        if(!flag) printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}
/*
(1) 如果该图存在环,那么给定的关系肯定是互相矛盾的。return 2
(2) 如果不存在环,但是拓扑排序结束后(所有的边都已经扫描完毕),
排序得到的序列中元 素的个数小于给定的元素个数,那么给定的关系不足以判断出全部元素的大小关系。 return 3
(3) 如果拓扑排序出来的序列中元素的个数等于给定的元素个数,那么给出的关系可以判断出 全部元素的大小关系。return 1
*/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值