poj 1128 Frame Stacking (建图+拓扑排序)

Frame Stacking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3684 Accepted: 1223

Description

Consider the following 5 picture frames placed on an 9 x 8 array. 
........ ........ ........ ........ .CCC....

EEEEEE.. ........ ........ ..BBBB.. .C.C....

E....E.. DDDDDD.. ........ ..B..B.. .C.C....

E....E.. D....D.. ........ ..B..B.. .CCC....

E....E.. D....D.. ....AAAA ..B..B.. ........

E....E.. D....D.. ....A..A ..BBBB.. ........

E....E.. DDDDDD.. ....A..A ........ ........

E....E.. ........ ....AAAA ........ ........

EEEEEE.. ........ ........ ........ ........

    1        2        3        4        5   

Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below. 

Viewing the stack of 5 frames we see the following. 
.CCC....

ECBCBB..

DCBCDB..

DCCC.B..

D.B.ABAA

D.BBBB.A

DDDDAD.A

E...AAAA

EEEEEE..






In what order are the frames stacked from bottom to top? The answer is EDABC. 

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules: 

1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters. 

2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides. 

3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.

Input

Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each. 
Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.

Output

Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).

Sample Input

9
8
.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..

Sample Output

EDABC

Source


题意:

一个二维图里面有几个相框(四条边的空心矩形框)。

有重叠,求重叠顺序。

思路:建图+拓扑排序

我是这样建图的 :

将每个矩形的上下左右边确定  然后扫描地图  对每个点 扫描矩形 如果这个点的位置同时也在另一个矩形框架内  则建边  

图建完后,就是dfs拓扑排序输出答案了  从小到大搜能保证搜出来的满足字典顺序

代码:(思路还是蛮清晰的  值得一看  嘻嘻 我还精心简化了一下代码滴)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <stack>
#define maxn 40
using namespace std;

int n,m,cnt;
int num[maxn];
char mp[maxn][maxn],ans[maxn],s[maxn];
bool vis[maxn],app[maxn];
vector<int>v[maxn];
stack<int>sta;
struct Node
{
    int u,d,l,r;
}node[maxn];          // 矩形框

void getnode()    // 得到矩形框
{
    int i,j,t;
    for(i=0;i<26;i++)
    {
        if(app[i])
        {
            node[i].u=node[i].l=maxn;
            node[i].d=node[i].r=0;
        }
    }
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(mp[i][j]=='.') continue ;
            t=mp[i][j]-'A';
            if(node[t].u>i) node[t].u=i;
            if(node[t].l>j) node[t].l=j;
            if(node[t].d<i) node[t].d=i;
            if(node[t].r<j) node[t].r=j;
        }
    }
}
void addedge()        // 建边
{
    int i,j,k,t;
    memset(num,0,sizeof(num));
    for(i=0;i<26;i++)
    {
        if(app[i])
        {
            v[i].clear();
        }
    }
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(mp[i][j]=='.') continue ;
            t=mp[i][j]-'A';
            for(k=0;k<26;k++)
            {
                if(app[k]&&k!=t)
                {
                    if(i>=node[k].u&&i<=node[k].d&&(j==node[k].l||j==node[k].r))
                    {
                        num[t]++;
                        v[k].push_back(t);
                    }
                    else if(j>=node[k].l&&j<=node[k].r&&(i==node[k].u||i==node[k].d))
                    {
                        num[t]++;
                        v[k].push_back(t);
                    }
                }
            }
        }
    }
}
void dfs(int k,int pos)    // 拓扑排序 输出答案
{
    ans[pos]='A'+k;
    if(pos>=cnt-1)
    {
        ans[cnt]='\0';
        printf("%s\n",ans);
        return ;
    }
    int i,j,sz,tmp[maxn];
    memcpy(tmp,num,sizeof(tmp));
    sz=v[k].size();
    for(i=0;i<sz;i++)
    {
        num[v[k][i]]--;
    }
    for(i=0;i<26;i++)
    {
        if(app[i]&&!num[i]&&!vis[i])
        {
            vis[i]=1;
            dfs(i,pos+1);
            vis[i]=0;
        }
    }
    memcpy(num,tmp,sizeof(tmp));
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        memset(app,0,sizeof(app));
        for(i=1;i<=n;i++)
        {
            scanf("%s",s);
            for(j=1;j<=m;j++)
            {
                mp[i][j]=s[j-1];
                if(s[j-1]!='.') app[s[j-1]-'A']=1;
            }
        }
        cnt=0;
        for(i=0;i<26;i++)
        {
            if(app[i]) cnt++;
        }
        getnode();
        addedge();
        memset(vis,0,sizeof(vis));
        for(i=0;i<26;i++)
        {
            if(app[i]&&!num[i])
            {
                vis[i]=1;
                dfs(i,0);
                vis[i]=0;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值