poj 3259 Wormholes (SPFA 判断有无负权回路)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25364 Accepted: 9072

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source


第一次用SPFA做最短路,还是贴一下吧,基本上就是裸题,就不多说了。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define maxn 505
#define maxx 5500
using namespace std;

int n,m,cxx,ans,cnt,sx;
bool vis[maxn];
int dist[maxn],p[maxn],num[maxn];
struct Node
{
    int r,cost;
    int next;
}edge[maxx];
queue<int>q;

void init()
{
    memset(vis,0,sizeof(vis));
    memset(p,0,sizeof(p));
    memset(num,0,sizeof(num));
    memset(dist,0x3f,sizeof(dist));
}
void addage(int u,int v,int w)
{
    cnt++;
    edge[cnt].r=v;
    edge[cnt].cost=w;
    edge[cnt].next=p[u];
    p[u]=cnt;
}
bool SPFA()
{
    int i,j,nx;
    sx=1;
    while(!q.empty()) q.pop();
    dist[sx]=0;
    vis[sx]=1;
    num[sx]++;
    q.push(sx);
    while(!q.empty())
    {
        nx=q.front();
        vis[nx]=0;
        q.pop();
        for(i=p[nx];i;i=edge[i].next)
        {
            if(dist[edge[i].r]>dist[nx]+edge[i].cost)
            {
                dist[edge[i].r]=dist[nx]+edge[i].cost;
                if(!vis[edge[i].r])
                {
                    vis[edge[i].r]=1;
                    num[edge[i].r]++;
                    if(num[edge[i].r]>n) return true ;
                    q.push(edge[i].r);
                }
            }
        }
    }
    return false ;
}
int main()
{
    int i,j,t,u,v,w;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&cxx);
        init();
        cnt=0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addage(u,v,w);
            addage(v,u,w);
        }
        for(i=1;i<=cxx;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addage(u,v,-w);
        }
        if(SPFA()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值