hdu 4576 : Robot

1 篇文章 0 订阅

Robot

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1600    Accepted Submission(s): 599


Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 

Sample Input
  
  
3 1 1 2 1 5 2 4 4 1 2 0 0 0 0
 

Sample Output
  
  
0.5000 0.2500
 

Source
 
 
算法:模拟
题目意思:

Robot绕圆(1-n)行走,有m个命令,随机选择方向,第i个命令行走mi个距离。求在lr的范围内的概率.

思路:

模拟,不超时。

构造两个数组,temp[]记录前一个状态,cnt[]记录当前状态(其初始化为0),将不为0temp[],进行移动,然后加到目的位置的cnt[]中。最后输出ans=temp[l]+...+temp[r];

 

代码:
#include <stdio.h>
#include <string.h>
#define N 201
double cnt[N],temp[N];
int main()
{
    int n,m,l,r,i,j,sum1,w,sum2,pos;
    double ans;
    while(scanf("%d%d%d%d",&n,&m,&l,&r)!=EOF && (n+m+l+r))
    {
        memset(cnt,0,sizeof(cnt));
        memset(temp,0,sizeof(temp));
        temp[1]=1;
        for(i=1;i<=m;++i)
        {
            scanf("%d",&w);//m个w
            for(j=1;j<=n;++j)
            {
                if(temp[j]==0)
                    continue;
                //顺时针
                pos=j+w%n;//确定位置
                if(pos>n)
                {
                    pos-=n;
                }
                cnt[pos]+=0.5*temp[j];

                //逆时针
                pos=j-w%n;
                if(pos<=0)
                {
                    pos+=n;
                }
                cnt[pos]+=0.5*temp[j];
            }

            for(j=1;j<=n;++j)
            {
                temp[j]=cnt[j];
                cnt[j]=0;
            }
        }

        sum1=sum2=0;
        ans=0;
        for(i=l;i<=r;++i)
        {
            ans+=temp[i];
        }
        printf("%.4lf\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值