HDOJ Text Reverse JAVA 1062

17 篇文章 0 订阅
7 篇文章 0 订阅



这个故事告诉我们   看似很简单的一道题也是有坑的。。

捣鼓了好久才找到PE的问题所在

package _1062;

import java.util.Scanner;

public class Main{
	public static void main(String[] args){
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		sc.nextLine();
		while((n--)!=0){
//			PE
//			输入qwe  rty  (这里y后面有两个空格)输入应该是ewq  ytr  (也有空格)
			
//			String s = sc.nextLine();
//			String [] ss = s.split(" ");
//			for (int i = 0; i < ss.length; i++) {
//				ss[i] = rev(ss[i]);
//			}
//			for (int i = 0; i < ss.length; i++) {
				if(ss[i].length()!=0){
//					if(i==ss.length-1)
//						System.out.print(ss[i]);
//					else
//						System.out.print(ss[i]+" ");
				}
//			}
//			if(n!=0)
//				System.out.println();
			
			String s = sc.nextLine();
			StringBuilder s1 = new StringBuilder();
			StringBuilder s2 = new StringBuilder();
			for (int i = 0; i < s.length(); i++) {
				if(s.charAt(i)!=' '){
					s2.append(s.charAt(i));
					if(i==s.length()-1){
						s2 = rev(s2);
						s1.append(s2);
						s2 = new StringBuilder();
					}
				}else {
					s2 = rev(s2);
					s2.append(' ');
					s1.append(s2);
					s2 = new StringBuilder();
				}
			}
			System.out.println(s1);
			
		}
	}

	private static StringBuilder rev(StringBuilder s2) {
		return s2.reverse();
	}

//	private static String rev(String string) {
//		String s = new StringBuilder(string).reverse().toString();
//		return s;
//	}

}


Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33697    Accepted Submission(s): 13297


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 

Author
Ignatius.L
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值