Phone List

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1075 1251 1247 1800 1677 



此题主要还是关于Trie树的应用


#include<stdio.h>
#include<stdlib.h>

#define MAX 10

typedef struct PhoneNode
{
    enum{true,false} isStr;//标记该节点为电话结尾
    struct PhoneNode *next[MAX];
}Phone;

char flag=0;//0:表明Yes   1:表明No

//将新号码插入至字典树
//插入过程还需判断是否插入的号码中带有结尾标记
//以及指向的下一个节点是否都是为空
void insert(Phone *root,const char *s)
{
    int i;
    Phone *p=root;
    Phone *temp;

    while(*s!='\0')
    {
        if(p->next[*s-'0']==NULL)//如果不存在,则建立节点
        {
            temp=(Phone *)malloc(sizeof(Phone));
            for(i=0;i<MAX;i++)
            {
                temp->next[i]=NULL;
            }
            temp->isStr=false;

            p->next[*s-'0']=temp;
        }
        if(p->isStr==true)
            flag=1;
        p=p->next[*s-'0'];
        s++;
    }
    p->isStr=true;//号码结束的地方标记此处可以构成一个电话
    for(i=0;i<MAX;i++)
    {
        if(p->next[i]!=NULL)
        {
            flag=1;
            break;
        }
    }
}

void del(Phone *root)
{
    int i;
    for(i=0;i<MAX;i++)
    {
        if(root->next[i]!=NULL)
        {
            del(root->next[i]);
        }
    }
    free(root);
}

int main(void)
{
   int t,n;//t为测试的例子 n为该组测试的号码数
   int i,j,k;
   char s[100];
   Phone *root=(Phone *)malloc(sizeof(Phone));

    for(i=0;i<MAX;i++)
    {
        root->next[i]=NULL;
    }
    root->isStr=false;

   scanf("%d\n",&t);
   for(j=0;j<t;j++)
   {
      scanf("%d\n",&n);
      for(k=0;k<n;k++)
      {
        scanf("%s",s);
        insert(root,s);
      }
      if(flag==0)
        printf("YES\n");
      else printf("NO\n");
      del(root);//释放空间

        root=(Phone *)malloc(sizeof(Phone));
        for(i=0;i<MAX;i++)
        {
            root->next[i]=NULL;
        }
        root->isStr=false;
      flag=0;
   }
   del(root);//释放空间
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值