Mobile Phones poj 1195--二维树状数组

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
 

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source



二维树状数组, 注意:数据输入可以从0开始,建立树状数组的时候一定注意!!!数据范围最坑爹啊。。。。。
代码如下:
#include<stdio.h>
#include<string.h>
#define length 1025
int c[length][length],n;
int lowbit(int x)
{return x&-x;}
void update(int x,int y,int v)
{
	for (int i = x; i <= n+1; i+=lowbit(i))
	{
		for (int j = y; j <= n+1; j+=lowbit(j))
		{
			c[i][j]+= v;;
		}
	}
}
int getsum (int x,int y)
{
	int sum = 0;
	for (int i = x; i > 0; i-=lowbit(i))
	{
		for (int j = y; j > 0; j-=lowbit(j))
		{
			sum+=c[i][j];
		}
	}
	return sum;
}
int main()
{
	int order,x,y,v,l,b,r,t,ans;
		memset(c,0,sizeof(c));
	while (scanf("%d",&order)!=EOF)
	{
		switch (order)
		{
		case(0):scanf("%d",&n);break;
		case(1):scanf("%d%d%d",&x,&y,&v);
				update(x+1,y+1,v);//一定要注意可能输入0,0.造成死循环!!!
				break;
		case(2):scanf("%d%d%d%d",&l,&b,&r,&t);
				l++;b++;r++;t++;
				ans = getsum(r,t)+getsum(l-1,b-1)-getsum(l-1,t)-getsum(r,b-1);
				printf("%d\n",ans);
				break;
		case(3):return 0;
		}
	}
}

这道题还能用二维线段树来做,贴一下老师的代码供大家学习(我还没看懂。。。)
//二维线段树做法
#include <iostream>
using namespace std;
#define MY_MAX 1100
int Tree[MY_MAX * 3][MY_MAX * 3];//二维线段树,每一行都是一棵完全二叉树,用于存放一棵x方向线段树,树节点只存放对应的区间(矩阵)的数字之和
int S; //矩阵宽度
void Add_x( int rooty, int rootx,int L,int R,int x ,int a)
//rooty是外维的节点,rootx是内维节点,rootx对应的区间是[L,R]
{
	Tree[rooty][rootx] += a;
	if( L == R )
			return;
	int mid = (L + R )/2;
	if( x <= mid )
			Add_x(rooty,( rootx<< 1) + 1, L ,mid, x, a);
	else
			Add_x(rooty,( rootx<< 1) + 2, mid + 1,R, x, a);
}
void Add_y(int rooty, int L,int R, int y, int x,int a)
//rooty 是外维(y方向)节点,其对应的区间是[L,R]
{
	Add_x( rooty,0, 1, S, x,a);
	if( L == R)
			return;
	int mid = (L + R )/2;
	if( y <= mid )
			Add_y( ( rooty << 1) + 1, L, mid,y, x, a);
	else
			Add_y( ( rooty << 1) + 2, mid+1, R, y, x, a);
}
int QuerySum_x(int rooty, int rootx, int L, int R ,int x1,int x2)
{
	if( L == x1 && R == x2)
		return Tree[rooty][rootx];
	int mid = ( L + R ) /2 ;

	if( x2 <= mid )
		return QuerySum_x( rooty, (rootx << 1) + 1,L, mid,x1,x2);
	else if( x1 > mid )
		return QuerySum_x( rooty, (rootx << 1) + 2,	  mid+1,R, x1,x2);
	else
		return QuerySum_x( rooty, (rootx << 1) + 1,L, mid ,x1,mid) +	QuerySum_x( rooty,(rootx << 1) + 2,mid + 1, R, mid + 1,x2);
}
int QuerySum_y(int rooty, int L, int R ,int y1, int y2, int x1,int x2)
{
	if( L == y1 && R == y2 )
		return QuerySum_x(rooty,0,1,S,x1,x2);
	int mid = ( L + R ) /2;

	if( y2 <= mid )
		return QuerySum_y( (rooty << 1) + 1, L,	mid ,y1,y2,x1,x2);
	if( y1 > mid )
		return QuerySum_y( (rooty << 1) + 2,	mid + 1,R, y1,y2,x1,x2);
	else
		return QuerySum_y( (rooty << 1) + 1, L,	mid ,y1,mid ,x1,x2) +	QuerySum_y( (rooty << 1) + 2,	mid + 1, R, mid + 1,y2 ,x1,x2);
}
int main()
{
	int cmd;int x,y,a,l,b,r,t; int Sum = 0;
	while( true) 
	{
		scanf("%d",&cmd);
		switch( cmd) 
		{
			case 0:
					scanf("%d",& S);
					memset( Tree,0,sizeof(Tree));
					break;
			case 1:
					scanf("%d%d%d",&x ,&y,&a);
					Add_y(0, 1,S, y + 1, x + 1, a);
					break;
			case 2:
					scanf("%d%d%d%d",&l , &b, &r,&t);
					l ++; b++; r ++; t ++;
					printf("%d\n",QuerySum_y(0,1,S,b,t,l,r));
					break;
			case 3:
					return 0;
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值