Stars poj 2532--树状数组

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25498 Accepted: 11150

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

 
题目大意:给 n 个*,每个 * 都一个坐标( x,y ) ,问对于每个 * ,其左下方共有多少个 * (包含左下方同行,同列的 *

y坐标从小到大排序,如果y相同,就暗x坐标从小到大排序。相当于按x轴建立一维树状数组,然后求相当于它前面比它小的个数即可。

依然注意离散化。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
#include<stdlib.h>
using namespace std;
#define MAX 50005
struct node
{
	int x,y;
	int ran;
}ord[MAX];
int c[MAX],a[MAX],N;
int lowbit(int x)
{
	return x&-x;
}
int get_sum(int x)
{
	int s = 0;
	for (;x > 0; x-=lowbit(x))
	{
		s += c[x];
	}
	return s;
}
void update(int p,int v)
{
	for (int i = p; i <=N; i+=lowbit(i))
	{
		c[i] += v;
	}
}
bool cmp1(node a,node b)
{
	if(a.x==b.x)return a.y<b.y;
	else return a.x<b.x;
}
int main()
{
	scanf("%d",&N);
	for (int i = 1; i <= N; i++)
	{
		scanf("%d%d",&ord[i].x,&ord[i].y);
		ord[i].ran = i;
	}
	sort(ord+1,ord+N+1,cmp1);
	for (int i = 1; i <= N; i++)//离散化
	{
		a[ord[i].ran] = i;
	}
	memset(c,0,sizeof(c));
	int ans[MAX];
	memset(ans,0,sizeof(ans));
	int x=0;
	for (int i = 1; i <= N; i++)
	{
		update(a[i],1);
		x= get_sum(a[i])-1;
		ans[x]++;
	}
	for (int j = 0; j < N; j++)
	{
		printf("%d\n",ans[j]);
	}	
	system("pause");
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值