背包(3)Hdu1712 ACboy needs your help(分组背包)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2710    Accepted Submission(s): 1390


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6
 

Source
 

Recommend
lcy
 


 

/* 
题意:给每种课程一定的复习时间,得到最大的复习效果,注意对一个科目只能复习一次。
分析:分组背包,每组的物品只能取一种。本题是对应一个科目复习一次。
*/
#include<cstdio> 
#include<cstring>
#include<algorithm>
using namespace std; 
int ans[101],a[101][101]; 
int main() 
{ 
    int n,m,i,j,k; 
    while(~scanf("%d%d",&n,&m)) 
    { 
        if(n==0&&m==0)break; 
		for (i = 1; i <= n; i++)
			for (j = 1; j <= m; j++)
				scanf("%d",&a[i][j]);			
		memset(ans,0,sizeof(ans));		
		for (i = 1; i <= n; i++)//背包
			for (k = m; k >= 0; k--)
				for(j = 0;j <= k;j++)
					ans[k] = max(ans[k],ans[k-j]+a[i][j]);			
		printf("%d\n",ans[m]);
	} 
    return 0; 
}
//队友写的二维的,也对
#include<stdio.h>
#include<string.h>
int max(int x,int y)
{return x>y?x:y;}
int a[101][101],ans[105][105];
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0 && m==0) break;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				scanf("%d",&a[i][j]);
			}
		}
		memset(ans,0,sizeof(ans));		
		for (int i = 1; i <= n; i++)//背包
		{
			for (int j = 1; j <= m; j++)
			{
				for (int k = j; k >= 0; k--)
				{
					ans[i][j] = max(ans[i][j],ans[i-1][j-k]+a[i][k]);
				}
			ans[i][j] = max(ans[i][j],ans[i][j-1]);
			}
		}
		printf("%d\n",ans[n][m]);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值