[C++] PAT 1022 Digital Library (30分)

在这里插入图片描述

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题解:

该题使用map<string,set<int>>相同信息id集对应

#include <iostream>
#include <string>
#include <map>
#include <set>

using namespace std;

int n;
map<string,set<int>> title,author,keywords,publisher,year;

void query(map<string,set<int>> &m,string &str){
	
	if(m.find(str) != m.end()){
		for(set<int>::iterator  i = m[str].begin();i !=m[str].end();i++){
			printf("%07d\n",*i);
		}
	
	}else{
		cout << "Not Found" << endl;
	}

}



int main(){

	cin >> n;

	int id;
	string t_title,t_author,t_key,t_publisher,t_year;
	for(int i=0;i<n;i++){
		cin >> id;
		getchar();

		getline(cin,t_title);
		title[t_title].insert(id);

		getline(cin,t_author);
		author[t_author].insert(id);

		while(cin >> t_key){
			keywords[t_key].insert(id);
		
			char c =getchar();

			if(c == '\n'){
				break;
			}
		
		}

		getline(cin,t_publisher);
		publisher[t_publisher].insert(id);

		getline(cin,t_year);
		year[t_year].insert(id);
	}
	
	int m;
	cin >> m;

	int num;
	string q;
	for(int i=0;i<m;i++){
		scanf_s("%d: ",&num);
		getline(cin,q);

		cout << num << ": " << q << endl;
		
		if(num == 1) query(title,q);
		else if(num == 2) query(author,q);
		else if(num == 3) query(keywords,q);
		else if(num == 4) query(publisher,q);
		else if(num == 5) query(year,q);
		
		

	}


	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值