[C++] PAT 1064 Complete Binary Search Tree (30分)

在这里插入图片描述

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题解:

在完全二叉搜索树中,其中序遍历必然是从小到大,可以直接对输入数据进行排序,直接得到其中序遍历;
再模拟一次中序遍历,将数组填充数字后就可以得到以数组方式存储的完全二叉搜索树;
直接输出数组即可得到其层次遍历

#include <iostream>
#include <algorithm>

using namespace std;


const int maxn = 1010;

int num[maxn];
int tree[maxn];
int n;
int index=0;

void order(int root){
	if(root > n){
		return;
	}
	
	order(2*root);
	tree[root] = num[index++];
	order(2*root + 1);
}




int main(){

	cin >> n;

	for(int i = 0; i < n; i++){
		scanf_s("%d",&num[i]);
	}

	sort(num,num+n);

	order(1);

	for(int i=1;i<=n;i++){
		
		cout << tree[i];

		if(i != n){
			cout << " ";
		}
	
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值