pat1064 Complete Binary Search Tree(树的遍历)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目给出一个完全二叉树的所有节点的值,让我们写出这个树的层序遍历。

完全二叉查找树特点:除了最下面一层之外,其余层节点都达到最大,只有最下一层节点从左至右连续存在若干节点。

二叉查找树的中序遍历有一个特点:是从小到大有序的。

把完全二叉查找树根节点设为1,可知左边的为2*index,右边2*index+1,所以可以写出下面的代码。

不断地2*root,到达最后一个2*root,也就是到达了最左边的节点,就是最小值,然后网上就是第二小,兄弟节点就是第三小(最后一个2*root+1) ,然后依次迭代。

#include <iostream>
#include "algorithm"

using namespace std;
const int maxx = 1010;
int n,number[maxx],CBT[maxx],index=0;
void inOrder(int root){
    if (root > n) return;
    inOrder(2*root);
    CBT[root] = number[index++];
    inOrder(2*root + 1);
}
int main() {
    scanf("%d",&n);
    for (int i = 0; i < n; ++i) {
        scanf("%d",&number[i]);
    }
    sort(number,number+n);
    inOrder(1);
    for (int i = 1; i <= n ; ++i) {
        printf("%d",CBT[i]);
        if (i<n) printf(" ");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值