连续子序列最大和问题
看了 http://blog.csdn.net/hcbbt/article/details/10454947 之后的产物。
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 136378 Accepted Submission(s): 31572
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
#include <iostream>
using namespace std;
int main() {
int num;
cin>>num;
for(int i = 0; i<num; i++)
{
int n, temp, sum, max, LEFT, left, RIGHT, right;
sum = max = -0xfffffff, LEFT = left = 0, RIGHT = right = 0;
cin>>n;
for(int j = 0; j<n; j++)
{
cin>>temp;
if( temp + sum < temp )
{
sum = temp;
left = j;
}
else
{
sum += temp;
}
if(sum > max)
{
max = sum;
LEFT = left;
RIGHT = j;
}
}
if(i) cout<<endl;
cout<<"Case "<<i+1<<":"<<endl<<max<<" "<<LEFT+1<<" "<<RIGHT+1<<endl;
}
return 0;
}
最大连续子序列
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17787 Accepted Submission(s): 7877
Problem Description
给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ...,
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个,
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和
为20。
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该
子序列的第一个和最后一个元素。
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个,
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和
为20。
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该
子序列的第一个和最后一个元素。
Input
测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。
Sample Input
6 -2 11 -4 13 -5 -2 10 -10 1 2 3 4 -5 -23 3 7 -21 6 5 -8 3 2 5 0 1 10 3 -1 -5 -2 3 -1 0 -2 0
Sample Output
20 11 13 10 1 4 10 3 5 10 10 10 0 -1 -2 0 0 0Huge input, scanf is recommended.HintHint
Source
动态规划:
#include <iostream>
using namespace std;
int main() {
int n;
cin>>n;
while(n)
{
int temp, sum, max, LEFT, left, RIGHT, right,first,last;
sum = max = -0xfffffff, LEFT = left = 0, RIGHT = right = 0;
for(int j = 0; j<n; j++)
{
cin>>temp;
if( j == 0 ) first = temp;
else if (j == n-1 ) last = temp;
if( temp + sum < temp )
{
sum = temp;
left = temp;
}
else
{
sum += temp;
}
if(sum > max)
{
max = sum;
LEFT = left;
RIGHT = temp;
}
}
if( max<0 ) cout<<0<<" "<<first<<" "<<last<<endl;
else cout<<max<<" "<<LEFT<<" "<<RIGHT<<endl;
cin>>n;
}
return 0;
}
关于分治,明天再说吧....ヾ(≧O≦)〃嗷~