2013 - ECJTU 暑期训练赛第四场-problem-C

C - C
Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input

n (0 < n < 20).
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input

     
     
6 8
 

Sample Output

     
     
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
经典DFS题,下面直接AC代码
#include<iostream>
#include<cmath>
const int MAX=100;
int prim[MAX];
int chucun[MAX];
int mark[MAX];
int n;
int count;
using namespace std;
int main()
{
	int i,p=1;
	void DFS(int x);
	bool prime(double x);
	while(cin>>n)
	{
		cout<<"Case "<<p++<<':'<<endl;
		chucun[0]=1;
		memset(mark,0,sizeof(mark));
		DFS(1);
		cout<<endl;
	}
}
bool prime(double x)
{
	int i;
	for(i=2;i<=sqrt(x);i++)
	{
		if(int(x)%i==0)
		return false;
	}
	return true;
}
void DFS(int x)
{
		if(x==n&&(prime(double(1+chucun[x-1]))))
		{
			for(int i=0;i<x;i++)
			{
				if(i==0)
				cout<<chucun[i];
				else
				cout<<" "<<chucun[i];
			}
			cout<<endl;
		}
		else
		{
			for(int i=2;i<=n;i++)
			{
				if(mark[i]||!prime(double(chucun[x-1]+i)))
				continue;
				mark[i]=1;
				chucun[x]=i;
				DFS(x+1);
				mark[i]=0;
			}
		}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值