2013 - ECJTU 暑期训练赛第八场-problem-D

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).

You should output S.
 

Input
The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.
 

Output
For each test of the input, print a line containing S.
 

Sample Input
   
   
5 -5 9 -5 11 20 0
 

Sample Output
   
   
40
这题就是求2段最大子序列和
AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<iomanip>
#include<cmath>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
const int MAX=100001;
const int INF=99999999;
int s[MAX];
int DP[MAX];
int Now[MAX];
using namespace std;
int Max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int n,i,j,sum;
    while(cin>>n,n)
    {
        for(i=1;i<=n;i++)
        {
            cin>>s[i];
        }
        memset(DP,0,sizeof(DP));
        memset(Now,0,sizeof(Now));
        sum=0;
        for(i=1;i<=2;i++)
        {
            sum=-INF;
            for(j=i;j<=n-2+i;j++)
            {
                DP[j]=Max(DP[j-1]+s[j],Now[j-1]+s[j]);
                Now[j-1]=sum;
                sum=Max(DP[j],sum);
            }
            Now[n-2+i]=sum;
        }
        cout<<sum<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值