杭电1068-Girls and Boys

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5600    Accepted Submission(s): 2500


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2

题目链接:点击打开链接

题目大意:

现在由N个同学,他们之间可能有一定的浪漫关系,给出存在浪漫关系的同学。现在一个研究者要找出一个最大的同学的集合,这个集合满足的条件是:任意两个同学都没有浪漫关系。求这个集合的最大人数。

解题思路:

二分图的最大独立集。

但是这道题有一点不同,它没有告诉我们是男生还是女生,所以我们需要进行拆点,把一个学生拆成一个男生和一个女生,然后求出最大匹配后除以2即可。

最大独立集是指在一个有N个顶点的图G中,选出m个点,这m个点任意2个点都没有边相连。二分图最大匹配是含有最大匹配数目的子图,一个匹配含有2个顶点,那么有2*最大匹配最大匹配含个顶点。

最大独立集 = 顶点数 - 2 * 最大匹配 + 最大匹配

先减去已经匹配的顶点数,共2 * 最大匹配个,然后发现对于最大匹配,在一边的点是不可能有边相连的,所以要加上一边的点,所以:

二分图最大独立集=顶点数  —  二分图最大匹配。

AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
const int MAX=501;
int map[MAX][MAX];
int mark[MAX];
int pipei[MAX];
int n;
using namespace std;
bool find(int x)
{
    int i;
    for(i=0;i<n;i++)
    {
        if(!mark[i]&&map[x][i])
        {
            mark[i]=1;
            if(pipei[i]==-1||find(pipei[i]))
            {
                pipei[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int i,j,m,x,y,sum;
    while(cin>>n)
    {
        memset(map,0,sizeof(map));
        memset(pipei,-1,sizeof(pipei));
        for(i=0;i<n;i++)
        {
            scanf("%d: (%d)",&x,&m);
            while(m--)
            {
                cin>>y;
                map[x][y]=1;
            }
        }
        sum=0;
        for(i=0;i<n;++i)
        {
            memset(mark,0,sizeof(mark));
            if(find(i))
            sum++;
        }
        cout<<n-sum/2<<endl;
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值