Hdu 1068 Girls and Boys【最大匹配】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9560 Accepted Submission(s): 4379


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output
  
  
5 2

给出每个人跟别人的所有关系,现找出一些人构成一个集体,要求任意两个人都没有关系,求这个集体最多有多少个人....


说句实话,也没想到是怎么做的,只感觉到要用到最大匹配的思想,但是其他的不知道怎么处理了,后来看了大神的解析,原来有一个公式:

最大独立集合的数量=顶点数-最大匹配数


然后就是无脑的匈牙利算法模板求最大匹配数了,当然,因数据给出的原因,求得的匹配的数量求得的是真实的匹配量的二倍,需要除以二,以防超时,用了邻接表......

ps:看到很多人2000Ms+的时间A掉的,时间限制是10kMs,估计暴力也能过的吧.....


#include<stdio.h>
#include<string.h>
const int maxn=10005;
int link[maxn],vis[maxn],head[maxn],cnt;
struct Edge
{
	int to,next;
}edge[maxn*maxn];

void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
	memset(link,-1,sizeof(link));
} 
 
void add(int u,int v)
{
	edge[cnt].to=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}

int dfs(int u)
{
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].to;
		if(!vis[v])
		{
			vis[v]=1;
			if(link[v]==-1||dfs(link[v]))
			{
				link[v]=u;
				return 1;
			}
		}
	}
	return 0;
}

int match(int n)//匹配
{
	int ans=0;
	for(int i=0;i<n;++i)
	{
		memset(vis,0,sizeof(vis));
		if(dfs(i))
		{
			++ans;
		}
	}
	return ans;
}

int main()
{
	int n,m;
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		init();
		for(int i=0;i<n;++i)
		{
			int m,a,b;
			scanf("%d: (%d)",&a,&m);//注意格式
			while(m--)
			{
				scanf("%d",&b);
				add(a,b);add(b,a);
			}
		}
		int tp=match(n);
		printf("%d\n",n-tp/2);
	}
	return 0;
}




内容概要:本文详细介绍了基于结构不变补偿的电液伺服系统低阶线性主动干扰抑制控制(ADRC)方法的实现过程。首先定义了电液伺服系统的基本参数,并实现了结构不变补偿(SIC)函数,通过补偿非线性项和干扰,将原始系统转化为一阶积分链结构。接着,设计了低阶线性ADRC控制器,包含扩展状态观测器(ESO)和控制律,用于估计系统状态和总干扰,并实现简单有效的控制。文章还展示了系统仿真与对比实验,对比了低阶ADRC与传统PID控制器的性能,证明了ADRC在处理系统非线性和外部干扰方面的优越性。此外,文章深入分析了参数调整与稳定性,提出了频域稳定性分析和b0参数调整方法,确保系统在参数不确定性下的鲁棒稳定性。最后,文章通过综合实验验证了该方法的有效性,并提供了参数敏感性分析和工程实用性指导。 适合人群:具备一定自动化控制基础,特别是对电液伺服系统和主动干扰抑制控制感兴趣的科研人员和工程师。 使用场景及目标:①理解电液伺服系统的建模与控制方法;②掌握低阶线性ADRC的设计原理和实现步骤;③学习如何通过结构不变补偿简化复杂系统的控制设计;④进行系统仿真与实验验证,评估不同控制方法的性能;⑤掌握参数调整与稳定性分析技巧,确保控制系统在实际应用中的可靠性和鲁棒性。 阅读建议:本文内容详尽,涉及多个控制理论和技术细节。读者应首先理解电液伺服系统的基本原理和ADRC的核心思想,然后逐步深入学习SIC补偿、ESO设计、控制律实现等内容。同时,结合提供的代码示例进行实践操作,通过调整参数和运行仿真,加深对理论的理解。对于希望进一步探索的读者,可以关注文中提到的高级话题,如频域稳定性分析、参数敏感性分析等,以提升对系统的全面掌控能力。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值