杭电2058-The sum problem

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12151    Accepted Submission(s): 3681


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
这里做了好久一直超时,最后看了别人代码,恍然大悟啊~~用等差数列前n项和公式就能搞定啊
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<iomanip>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<stack>
#include<map>
#include<cmath>
using namespace std;
int main()
{
    __int64 n,m,i,j,a;//假设所求区间为[j,i];
    while(cin>>n>>m&&(n||m))
    {
        for(a=sqrt(double(2*m));a>=1;a--)//那么假设a为区间的长度即从j到i的长度
        {
            j=(2*m/a+1-a)/2;//根据等差数列前n项和公式(首项+末项)乘于a(区间长度)再除于2就等于m了(即:(((j+i)*a)/2=m))因为这里等差为1所以i=j+a-1 ==> ((j+a-1+j)*a)/2=m ==> j=(2*m/a+1-a)/2所以这里直接暴力枚举就OK了
            i=(j+a-1);
            if((j+i)*a==2*m)
            {
                cout<<'['<<j<<','<<i<<']'<<endl;
            }
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值