杭电---2058 The sum problem

Problem Description 

Given a sequence 1,2,3,......N, your job isto calculate all the possible sub-sequences that the sum of the sub-sequence isM.

 Input

 Input contains multiple test cases. each case contains two integers N,M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

 Output

 For each test case, print all the possible sub-sequence that its sum isM.The format is show in the sample below.print a blank line after each testcase.

 Sample Input 

20 10

50 30

0 0

Sample Output

[1,4]

[10,10]


[4,8]

[6,9]

[9,11]

[30,30]


Author

8600

 Source

 校庆杯Warm Up

 Recommend

 linle

分析:这是一道数学题,看了好久还是不会做,就上网看了别人的博客,找规律的题,a+1,a+2,a+3......a+len; 如果a+1+a+2+a+3.....+a+len=m(a+1+a+len)*len/2=m;len也就是数字的长度,a=0时,(len+1)*len/2=m;len取最大值就是;(a+1+a+len)*len/2=m,a*len+(len+1)*len/2=m,a=(m-(len+1)*len/2 )/len;a是大于0的数,,,真心的感觉数学好差,有种泪奔的感觉

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    __int64 n,m;
    __int64 len,d;
    while(cin>>n>>m)
    {
        if(m==0&&n==0)
            break;
        len=(int)sqrt(2.0*m);
        for(int i=len;i>0;i--)
        {
            d=m-i*(i+1)/2;
            if(d%i==0)
            {
                printf("[%I64d,%I64d]\n",d/i+1,d/i+i);
            }
        }
        printf("\n");
    }
    return 0;

}






 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值