HDU 杭电2579 Dating with girls(2) 【BFS】

http://acm.hdu.edu.cn/showproblem.php?pid=2579


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
 
//标准的BFS,由于走过的路可以重复k次,为的是担心出现这种情况
//一开始我在比赛的时候没有注意到这种情况,所以又是一直WA

/*
Input:

1
6 6 3
......
...#..
.#....
...#..
...#Y.
..#G##
Output:

4

*/

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define MAXN 110
using namespace std;
struct node
{
    int x,y;
    int time;
    /*friend bool operator < (node a,node b)
    {
        return a.time>b.time;
    }*/
};
int row,column,k;
char map[MAXN][MAXN];
node s,e;
int x[4]={1,-1,0,0};
int y[4]={0,0,1,-1};
bool vis[MAXN][MAXN][20];
bool judge(int x,int y,int time)
{
    if(x>row||x<=0||y>column||y<=0||vis[x][y][time%k]) return 0;
    if(map[x][y]=='#')
    {
        if(time%k==0) return 1;
        return 0;
    }
    return 1;
}
int BFS()
{
    node pos,next;
    memset(vis,0,sizeof(vis));
    queue<node>q;
    vis[s.x][s.y][0] = 1;
    s.time = 0;
    q.push(s);    
    while(!q.empty())
    {
        pos=q.front();
        q.pop();
        for(int i=0;i<4;++i)
        {
            next.x=pos.x+x[i];
            next.y=pos.y+y[i];
            next.time = pos.time+1;
            if(judge(next.x,next.y,next.time))
            {
                if(next.x==e.x&&next.y==e.y) return next.time;
                vis[next.x][next.y][next.time%k]=1;
                q.push(next);
            }
        }
    }
    return -1;
}
int main()
{
    int T;
    int i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&row,&column,&k);
        getchar();
        for(i=1;i<=row;++i)
        {
            for(j=1;j<=column;++j)
            {
                scanf("%c",map[i]+j);
                if(map[i][j]=='G')
                {
                    e.x=i;e.y=j;
                }
                else if(map[i][j]=='Y')
                {
                    s.x=i,s.y=j;
                }
            }
            getchar();
        }
        int res=BFS();
        if(res==-1) printf("Please give me another chance!\n");
        else printf("%d\n",res);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值