poj 2593

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 


You should output S. 

Input


The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.


Output


For each test of the input, print a line containing S.

Sample Input


-5 9 -5 11 20 
0


Sample Output


40


额, 算法弱菜写这些真不容易
一道很简单的动态规划,枚举出所有情况前后各部分最大子串的和,取最大值即可

#include <iostream>
#include <cstdio>
#include <climits>

int main()
{
    int m, i, s, max, a[100001], pre[100001];
    
    while (std::cin >> m, m) {
        s = 0;
        max = INT_MIN;
        for (i = 0; i != m; ++i) {
            scanf("%d", &a[i]);
            s += a[i];
            if (s > max) {
                max = s;
            }
            pre[i] = max;
            if (s < 0) {
                s = 0;
            }
        }
        s = 0;
        max = INT_MIN;
        for (i = m - 1; i != 0; --i) {
            s += a[i];
            if (s + pre[i - 1] > max) {
                max = s + pre[i - 1];
            }
            if (s < 0) {
                s = 0;
            }
        }
        std::cout << max << std::endl;
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值