华为HCNA路由与交换eNSP实战(5)RIPv2基础配置

前言

 
         由于RIPv1在现网中很少见,并且很难去部署了,所以,本章我们主要介绍RIPv2怎么配置并且怎么使用。         
         RIPv2是RIPv1的升级版本,具有比RIPv1更好的性能,比如RIPv2是无类路由协议,可以支持VLSM和CIDR的网络,这是我们现在网络中必须的要求,并且RIPv2是组播更新路由,更加高效,RIPv2还提供了安全认证的支持,可以提高网络的安全性,以及可以为路由配置TAG等功能,所以我们会选择RIPv2部署在网络中,而不是RIPv1。实验拓扑【誉天教育|解忧杂货店】RIPv2基础配置--华为数通R&S实验漫载(8)-2699139-2网络规划
 设备端口 IP地址
 AR1-G0/0/0 172.16.12.1/24
 AR2-G0/0/0 172.16.12.2/24
 AR2-G0/0/1 192.168.23.2/24
 AR3-G0/0/1 192.168.23.3/24
 AR3-Loopback0 10.1.3.3/32

 

 

实验目的

 
       在AR1、AR2和AR3之间部署RIPv2,并将AR3的Loopback0接口通告进RIPv2,使得AR1和AR2都可以学习到AR3的Loopback0接口的路由,并能够访问。
 

配置思路

 
1、配置路由器的接口IP地址
2、在AR1、AR2和AR3之间配置RIPv2
 

配置过程

 
1、在AR1、AR2和AR3上根据网络规划表配置IP地址。配置如下:
AR1的配置:
<Huawei>system-view
[Huawei]sysname AR1
[AR1]interface GigabitEthernet 0/0/0
[AR1-GigabitEthernet0/0/0]ip address 172.16.12.1 24
[AR1-GigabitEthernet0/0/0]quit

AR2的配置:
<Huawei>system-view
[Huawei]sysname AR2
[AR2]interface GigabitEthernet 0/0/0
[AR2-GigabitEthernet0/0/0]ip address 172.16.12.2 24
[AR2-GigabitEthernet0/0/0]quit
[AR2]interface GigabitEthernet 0/0/1
[AR2-GigabitEthernet0/0/1]ip address 192.168.23.2 24
[AR2-GigabitEthernet0/0/1]quit

AR3的配置:
<Huawei>system-view
[Huawei]sysname AR3
[AR3]interface GigabitEthernet 0/0/1
[AR3-GigabitEthernet0/0/1]ip address 192.168.23.3 24
[AR3-GigabitEthernet0/0/1]quit
[AR3]interface LoopBack 0
[AR3-LoopBack0]ip address 10.1.3.3 32
[AR3-LoopBack0]quit

 

2、在AR1、AR2和AR3上部署RIPv2协议,并将AR3的loopback0接口通告进RIPv2。其中由于RIP默认运行的版本不是v2(这个默认的版本也不是v1,我们会在后面的教程中介绍),所以需要修改RIP的运行版本。
       需要使用network命令通告设备间互联接口以及AR3的loopback0接口(多数路由协议在华为设备中都是使用network命令以在接口下开启协议功能)。注意,此时通告的为接口IP地址所在主类网络号,比如AR1和AR2的直连接口为172.16.12.0/24的网段(实际该网段是经过了子网划分的),但是在通告该接口时需要通告172.16.0.0,因为172是B类IP地址,其主类网络位为16位,所以仅通告其接口的IP地址的前16位,后面置0,所以192.168.23.0/24是C类地址,所以通告其前24位为192.168.23.0,10.1.3.3/32为A类地址,通告其前8位为10.0.0.0。配置如下:
AR1的配置:
[AR1]rip 1     //进入RIP进程1,一台设备可以运行多个进程,就像QQ与一样
[AR1-rip-1]version 2     //运行RIP版本2
[AR1-rip-1]network 172.16.0.0     //通告和AR2直连接口IP地址所在主类网络号
[AR1-rip-1]quit
AR2的配置:
[AR2]rip 1
[AR2-rip-1]version 2
[AR2-rip-1]network 172.16.0.0    //通告和AR1直连接口IP地址所在主类网络号
[AR2-rip-1]network 192.168.23.0     //通告和AR3直连接口IP地址所在主类网络号
[AR2-rip-1]quit

AR3的配置:
[AR3]rip 1
[AR3-rip-1]version 2
[AR3-rip-1]network 192.168.23.0    //通告和AR2直连接口IP地址所在主类网络号
[AR3-rip-1]network 10.0.0.0    //通告loopback0接口IP地址所在主类网络号
[AR3-rip-1]quit

 

配置验证

 

1、使用display ip routing-table protocol static命令验证AR1和AR2是否学习到AR3的loopback0接口的路由。测试输出如下:
【誉天教育|解忧杂货店】RIPv2基础配置--华为数通R&S实验漫载(8)-2699139-3
 

【誉天教育|解忧杂货店】RIPv2基础配置--华为数通R&S实验漫载(8)-2699139-4

       通过上面输出可见,AR1和AR2已经正常学习到了AR3的loopback0接口的路由,是通过RIP学习到的,接下来在AR1和AR2上使用ping命令进行连通性测试。
2、在AR1和AR2上使用ping命令对AR3的loopback0接口进行连通性测试。测试输出如下:【誉天教育|解忧杂货店】RIPv2基础配置--华为数通R&S实验漫载(8)-2699139-5

【誉天教育|解忧杂货店】RIPv2基础配置--华为数通R&S实验漫载(8)-2699139-6
 

原理总结


         RIP路由协议是我们在网络中部署的路由协议之一,我们经常使用RIP的版本2,但是实际上由于RIP协议自身的一些弊端,比如基于距离矢量的路由协议,收敛速度慢等等,所以我们目前在大型网络中一般不会选择RIP路由协议,而是OSPF或者IS-IS,但是由于RIP配置简单,消耗资源小,所以经常在网络的边缘或者小型网络使用。


 

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页