题目链接:
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=996
Problem A
Hashmat the brave warrior
Input: standard input
Output: standard output
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.
Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.
Output
For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.
Sample Input:
10 1210 14
100 200
Sample Output:
24
100
代码+分析:
- /*
- *两个易错点:
- * 1) The input numbers are not greater than 2^32
- * 表示输入可以为2^32 > 2^32-1,int最大值,所以用long long int
- * 2) These two numbers in each line denotes the number of
- * soldiers in Hashmat's army and his opponent's army
- * or vice versa.
- * or vice versa,表示输入的两个数不确定谁是谁的,但是HashMat的必然少。
- */
- #include <iostream>
- using namespace std;
- int main()
- {
- //freopen("f:\\input.txt", "r", stdin);
- long long int a, b, c;
- while(cin >> a >> b)
- {
- b - a > 0 ? c = b - a : c = a - b;
- cout << c << endl;
- }
- return 0;
- }