http://sdjzu.acmclub.com/index.php?app=problem_title&cid=1160&problem_id=A
题目描述
人生三大幻觉是手机在震动、有人叫你、还有Ta喜欢你。可是这第三条幻觉偏偏就真正的发生在了坤哥身上,坤哥很是高兴。但是......,那妹子对坤哥说了“我脖子上戴的这串项链有n个珠子,可以用c种颜色对珠子涂染,你能告诉我能形成多少种不同的项链吗?”这下可难为坤哥,没想到把个妹子还这么难,你能帮助坤哥把妹成功吗?
输入格式
包含多组测试数据,每组测试数据包含两个整数n和c.(1<=n,c<=10)
输出
输出能够形成多少种不同的项链。
样例输入
1 1
2 1
2 2
5 1
2 5
2 6
6 2
样例输出
1
2
3
5
8
13
21
代码实现:
#include<iostream>
using namespace std;
int main()
{
int gcd(int a,int b);
int c,s;
while(cin>>c>>s)
{
if(c==0&&s==0)
break;
int k;
long long p[64];
p[0]=1;
for(k=0;k<s;++k)
p[k+1]=p[k]*c;
long long count=s&1?s*p[s/2+1]:(s/2)*(p[s/2]+p[s/2+1]);
for(k=1;k<=s;++k)
count+=p[gcd(k,s)];
count/=2*s;
cout<<count<<endl;
}
return 0;
}
int gcd(int a,int b)
{
int c;
if(a==0)
return b;
while(b!=0)
{
c=b;
b=a%b;
a=c;
}
return a;
}