acd LCM Challenge(求1~n的任意三个数的最大公倍数)

Problem Description

Some days ago, I learned the concept of LCM (least common multiple). I've played with it for several times and I want to make a big number with it.

But I also don't want to use many numbers, so I'll choose three positive integers (they don't have to be distinct) which are not greater thann. Can you help me to find the maximum possible least common multiple of these three integers?

Input
The first line contains an integer n (1 ≤ n ≤ 10^6) — the n mentioned in the statement.
Output
Print a single integer — the maximum possible LCM of three not necessarily distinct positive integers that are not greater than n.
Sample Input
9
Sample Output
504
只要这三个数中有两个数是奇数一个是偶数,最小公倍数就是这三个数的积。
#include<stdio.h>
int main()
{
    long long  LCM,n;
    while(scanf("%lld",&n)>0)
    {
        if(n==1)LCM=1;
        if(n==2)LCM=2;
        if(n>2)
        {
            if(n%2)LCM=n*(n-1)*(n-2);
            else
            {
                if(n*(n-1)*(n-2)/2<n*(n-1)*(n-3))
                    LCM=n*(n-1)*(n-3);
                else LCM=n*(n-1)*(n-2)/2;
            }
        }
        printf("%lld\n",LCM);
    }
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值