hdu1150Machine Schedule (二分匹配,最小顶点覆盖)

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output
The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0

Sample Output
  
  
3
题目大意;有两台机器A和B以及N个需要运行的任务。每台机器有M种不同的模式,而每个任务都恰好在一台机器上运行。如果它在机器A上运行,则机器A需要设置为模式xi,如果它在机器B上运行,则机器B需要设置为模式yi。每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重启一次。请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。
解题:以每一个任务为一条边,但是以模式0顶点的就不需要算进去了,因为一开始就机器就是模式0不需要手动重新调模式。现在需要求的是最少手动调模式完成所有的任务,也就是最小顶点数覆盖所有的边。 而最小顶点覆盖=最大匹配。
#include<stdio.h>
#include<string.h>
int map[105][105],vist[105],match[105],n,m;
int find(int u)
{
    for(int v=0;v<m;v++)
    if(!vist[v]&&map[u][v])
    {
        vist[v]=1;
        if(match[v]==-1||find(match[v]))
        {
            match[v]=u; return 1;
        }
    }
    return 0;
}
int main()
{
    int k,a,x,y;
    while(scanf("%d",&n)>0&&n)
    {
        scanf("%d%d",&m,&k);
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        map[i][j]=0;
        for(int i=0;i<k;i++)
        {
            scanf("%d%d%d",&a,&x,&y);
            if(x&&y) map[x][y]=1;//一个边表示一个任务,其中任意一个模式为0的那么做这个任务不需要调
        }
        memset(match,-1,sizeof(match));
        int ans=0;
        for(int i=0;i<n;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",ans);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值