HDU1845 Jimmy’s Assignment(最大匹配)卡时间

Jimmy’s Assignment

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1093    Accepted Submission(s): 446


Problem Description
Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the maximum cardinality.
  Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance.
 

Input
The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input.
 

Output
For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching.
 

Sample Input
  
  
2 4 1 2 1 3 1 4 2 3 2 4 3 4 4 1 2 1 3 1 4 2 3 2 4 3 4
 

Sample Output
  
  
2 2
 

Author
Mugurel Ionut Andreica
 

Source
题意:求最大匹配的边数,每个顶点最多只能用一次。
解题:用二分匹配算法。很卡时间,while 比 for 循环快,所以尽可能的用while ,初始化用 memset 。 889MS   AC
</pre><pre name="code" class="cpp">#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
const int N = 5005;

int head[N], to[N *10], next1[N *10], tot;
int mach[N];
bool vist[N];

void addEdge(const int& u, const int& v) {
  to[tot] = v, next1[tot] = head[u], head[u] = tot++;
}
void addUndirEdge(const int& u, const int& v) {
  addEdge(u, v), addEdge(v, u);
}
void init(){
    tot=0;
    memset(mach,-1,sizeof(mach));
    memset(head,-1,sizeof(head));
}
bool findroad(int u){
    int i=head[u];
    while(i!=-1){
        int v=to[i]; i=next1[i];
        if(!vist[v]){
            vist[v]=1;
            if(mach[v]==-1||findroad(mach[v])){
                mach[v]=u;  return true;
            }
        }
    }
    return false;
}

int main(){
    int n,T,u,v;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        init();
        int m=3*n/2;
       while(m--){
            scanf("%d%d",&u,&v);
            addUndirEdge(u,v);
        }
        int ans=0;
        while(n){
            if(head[n]!=-1) {
                memset(vist,0,sizeof(vist));
                ans+=findroad(n);
            }
            n--;
        }
        printf("%d\n",ans/2);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值