C - Hyperhuffman(哈弗曼值)

C - Hyperhuffman

Time Limit:  20000/10000MS (Java/Others)  Memory Limit:  128000/64000KB (Java/Others)
Problem Description

      You might have heard about Huffman encoding - that is the coding system that minimizes the expected length of the text if the codes for characters are required to consist of an integral number of bits.

      Let us recall codes assignment process in Huffman encoding. First the Huffman tree is constructed. Let the alphabet consist of N characters, i-th of which occurs Pi times in the input text. Initially all characters are considered to be active nodes of the future tree, i-th being marked with Pi. On each step take two active nodes with smallest marks, create the new node, mark it with the sum of the considered nodes and make them the children of the new node. Then remove the two nodes that now have parent from the set of active nodes and make the new node active. This process is repeated until only one active node exists, it is made the root of the tree.

      Note that the characters of the alphabet are represented by the leaves of the tree. For each leaf node the length of its code in the Huffman encoding is the length of the path from the root to the node. The code itself can be constrcuted the following way: for each internal node consider two edges from it to its children. Assign 0 to one of them and 1 to another. The code of the character is then the sequence of 0s and 1s passed on the way from the root to the leaf node representing this character.

      In this problem you are asked to detect the length of the text after it being encoded with Huffman method. Since the length of the code for the character depends only on the number of occurences of this character, the text itself is not given - only the number of occurences of each character. Characters are given from most rare to most frequent.

      Note that the alphabet used for the text is quite huge - it may contain up to 500 000 characters.

Input
      The first line of the input file contains N - the number of different characters used in the text (2 ≤ N ≤ 500 000). The second line contains N integer numbers P i - the number of occurences of each character (1 ≤ P i ≤ 10 9, P i ≤ P i+1 for all valid i).
Output
      Output the length of the text after encoding it using Huffman method, in bits.
Sample Input
3
1 1 4
Sample Output
8
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
#define ll long long
typedef struct nnn
{
    ll sum,v;
    friend bool operator<(struct nnn a,struct nnn b)
    {
        return a.v>b.v;
    }
}node;
priority_queue<node>q;
ll count()
{
    node p1,p2;
    while(!q.empty())
    {
        p1=q.top(); q.pop();
        if(q.empty()) 
        return p1.sum;
        p2=q.top(); q.pop();
        p1.sum+=p2.sum+p1.v+p2.v;
        p1.v+=p2.v;
        q.push(p1);
    }
}
int main()
{
    node p;
    int n;
    while(scanf("%d",&n)>0)
    {
        while(!q.empty())q.pop();
        while(n--)
        {
            scanf("%lld",&p.v);
            p.sum=0; q.push(p);
        }
        printf("%lld\n",count());
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值