find the longest of the shortest
Time Limit: 1000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2076 Accepted Submission(s): 732
Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
Sample Input
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
Sample Output
11 13 27
Author
ailyanlu
题意:给出一个图,图中有一条边正在修理,无法通行,现在问从1走到n点,最短路中的最长路是多少。
分析:先求一次最短路,并把边记录下来,接下来就是在这些边中枚举删除一条边求一次最短路,找到最大值。
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
const int N = 1005;
const int inf = 999999999;
struct EDG
{
int v,d;
};
vector<EDG>mapt[N];
bool inq[N];
int dis[N],frome[N],n;
void init()
{
for(int i=1;i<=n;i++)
mapt[i].clear();
}
inline void spfa(const int u,const int v,bool recode)
{
queue<int>q;
int s;
for(int i=1;i<=n;i++)
dis[i]=inf,inq[i]=false;
inq[n]=true;
dis[1]=0; q.push(1); frome[1]=1;
while(!q.empty())
{
s=q.front(); q.pop();
inq[s]=false;
for(int i=0;i<mapt[s].size();i++)
{
int now=mapt[s][i].v;
if(s==u&&now==v||s==v&&now==u)
continue;
if(dis[now]>dis[s]+mapt[s][i].d)
{
dis[now]=dis[s]+mapt[s][i].d;
if(recode) frome[now]=s;
if(!inq[now])
inq[now]=true,q.push(now);
}
}
}
}
int main()
{
int m,a,b,ans;
EDG edg;
while(scanf("%d%d",&n,&m)>0)
{
init();
while(m--)
{
scanf("%d%d%d",&a,&b,&edg.d);
edg.v=b; mapt[a].push_back(edg);
edg.v=a; mapt[b].push_back(edg);
}
spfa(0,0,true);
ans=0; a=n;
while(frome[a]!=a)
{
b=frome[a];
spfa(a,b,false);
if(dis[n]>ans)
ans=dis[n];
a=b;
}
printf("%d\n",ans);
}
}