HDU3631Shortest Path(Floyd的巧妙应用)经典

Shortest Path

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4379    Accepted Submission(s): 1029


Problem Description
When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?
 

Input
The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.
 

Output
Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.
 

Sample Input
  
  
5 10 10 1 2 6335 0 4 5725 3 3 6963 4 0 8146 1 2 9962 1 0 1943 2 1 2392 4 2 154 2 2 7422 1 3 9896 0 1 0 3 0 2 0 4 0 4 0 1 1 3 3 1 1 1 0 3 0 4 0 0 0
 

Sample Output
  
  
Case 1: ERROR! At point 4 ERROR! At point 1 0 0 ERROR! At point 3 ERROR! At point 4
 

Source

 

题意:给出n个点0~(n-1),m条边(单向),q次操作。操作有两种:0:标记x点,如果标记了就输出"ERROR! At point x”。    1: 问从 x 到 y 的最短路(x,y和经过的点都必须被      标记过),如果x,或y没有被标记过输出“ERROR! At path x to y”,如果没有路输出“No such path”。

对于这个题Floyd就非常适用了,只要标记一个点,就以这个点作为中间结点,缩短一下任意两点节点之间的距离。整个过程的时间复杂度最多为O(n^3+q)。

#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
const int N = 1005;
const int inf = 999999999;

int mark[N],n,mapt[N][N];
void init()
{
    for(int i=0;i<=n;i++)
    {
        mark[i]=0;
       for(int j=0;j<=n;j++)
        mapt[i][j]=inf;
        mapt[i][i]=0;
    }
}
void floyd(int k)
{
    for(int i=0;i<n;i++)
    if(i!=k)
    for(int j=0;j<n;j++)
    if(i!=j&&k!=j)
    {
        if(mapt[i][j]>mapt[i][k]+mapt[k][j])
            mapt[i][j]=mapt[i][k]+mapt[k][j];
    }
}
int main()
{
    int cas=0,m,q,a,b,c,op,flag=0;
    while(scanf("%d%d%d",&n,&m,&q)>0)
    {
        if(n+m+q==0)
            break;
        if(flag)
            printf("\n");
        flag=1;
        init();
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c<mapt[a][b])
                mapt[a][b]=c;
        }

        printf("Case %d:\n",++cas);
        while(q--)
        {
            scanf("%d%d",&op,&a);
            if(op==0)
            {
                if(mark[a])
                    printf("ERROR! At point %d\n",a);
                else
                {
                    mark[a]=1; floyd(a); //标记一次求一次floyd
                }
            }
            else
            {
                scanf("%d",&b);
                if(mark[a]==0||mark[b]==0)
                    printf("ERROR! At path %d to %d\n",a,b);
                else if(mapt[a][b]<inf)
                   printf("%d\n",mapt[a][b]);
                else
                   printf("No such path\n");
            }
        }
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值