HDU3768 Shopping(状态压缩DP+spfa)旅行商问题

Shopping

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 577    Accepted Submission(s): 197


Problem Description
You have just moved into a new apartment and have a long list of items you need to buy. Unfortunately, to buy this many items requires going to many different stores. You would like to minimize the amount of driving necessary to buy all the items you need.

Your city is organized as a set of intersections connected by roads. Your house and every store is located at some intersection. Your task is to find the shortest route that begins at your house, visits all the stores that you need to shop at, and returns to your house.
 

Input
The first line of input contains a single integer, the number of test cases to follow. Each test case begins with a line containing two integers N and M, the number of intersections and roads in the city, respectively. Each of these integers is between 1 and 100000, inclusive. The intersections are numbered from 0 to N-1. Your house is at the intersection numbered 0. M lines follow, each containing three integers X, Y, and D, indicating that the intersections X and Y are connected by a bidirectional road of length D. The following line contains a single integer S, the number of stores you need to visit, which is between 1 and ten, inclusive. The subsequent S lines each contain one integer indicating the intersection at which each store is located. It is possible to reach all of the stores from your house.
 

Output
For each test case, output a line containing a single integer, the length of the shortest possible shopping trip from your house, visiting all the stores, and returning to your house.
 

Sample Input
  
  
1 4 6 0 1 1 1 2 1 2 3 1 3 0 1 0 2 5 1 3 5 3 1 2 3
 

Sample Output
  
  
4
 

Source
University of Waterloo Local Contest 2010.07.10
题意:给出n个点,m条路,s(1<=s<=10)个店位于n个地方,现在要求从0点出发走完所有的店的最小花费。
解题:先求出店与店之间的最短路,包括出发点0,然后就是状态压缩dp。
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
#define mov(a) (1<<(a))
const int N = 100005;
const int inf = 99999999;
struct EDG{
    int v,c;
};

int dis[N],inq[N],mark[N],n,road[15][15],dp[mov(12)][12];
vector<EDG>mapt[N];

void spfa(int s)
{
    queue<int>q;
    for(int i=0;i<=n;i++)
        dis[i]=inf,inq[i]=0;
    dis[s]=0;
    q.push(s);
    while(!q.empty())
    {
        s=q.front(); q.pop();
        inq[s]=0;
        int k=mapt[s].size();
        for(int i=0;i<k;i++)
        {
            int v=mapt[s][i].v;
            if(dis[v]>dis[s]+mapt[s][i].c)
            {
                dis[v]=dis[s]+mapt[s][i].c;
                if(inq[v]==0)
                    inq[v]=1,q.push(v);
            }
        }
    }
}
int main()
{
    int t,m,s,a,b,store[15];
    EDG ss;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            mapt[i].clear(),mark[i]=-1;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&ss.c);
            ss.v=b; mapt[a].push_back(ss);
            ss.v=a; mapt[b].push_back(ss);
        }
        scanf("%d",&s);
        store[0]=0; mark[0]=0; s++;
        for(int i=1;i<s;i++)
        {
            scanf("%d",&store[i]); mark[store[i]]=i;
        }


        for(int i=0;i<s;i++)//求出店与店之间的最短路
        {
            spfa(store[i]);
            for(int j=0;j<n;j++)
            if(mark[j]>=0)
                road[i][mark[j]]=dis[j];
        }
        
        for(int sta=0;sta<mov(s);sta++)
            for(int i=0;i<s;i++)
            dp[sta][i]=inf;
        dp[1][0]=0;
        for(int sta=1;sta<mov(s);sta++)
        for(int i=0;i<s;i++)
        if(dp[sta][i]!=inf)
        {
            for(int j=1;j<s;j++)
            if((sta&mov(j))==0)
            {
                if(dp[sta|mov(j)][j]>dp[sta][i]+road[i][j])
                    dp[sta|mov(j)][j]=dp[sta][i]+road[i][j];
            }
        }
        int ans=inf;
        for(int i=0;i<s;i++)
        if(dp[mov(s)-1][i]+road[i][0]<ans)
        ans=dp[mov(s)-1][i]+road[i][0];

        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值