HDU 1845(匈牙利算法求最大匹配)卡常

Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the maximum cardinality.
Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance.
Input
The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input.
Output
For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching.
Sample Input
2
4
1 2
1 3
1 4
2 3
2 4
3 4
4
1 2
1 3
1 4
2 3
2 4
3 4
Sample Output
2
2

别的就不多说了,主要是这数据有点恶心,存边需要用链式前向星(vector貌似也OK的),双向存边,最后ans/2就行了。

#include <iostream>
#include <stdio.h>
#include <string>
#include<cstring>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int maxn = 5005;
int n,m;
int nxt[maxn];
bool note[maxn];
int head[maxn],cnt;
struct st{
    int ed,next;
}edge[maxn*5];
void add(int st,int ed){
     edge[cnt].ed=ed;
     edge[cnt].next=head[st];
     head[st]=cnt;
     ++cnt;
}
bool find(int x)
{
     for(int i=head[x];i!=-1;i=edge[i].next){
         int v=edge[i].ed;
         if(!note[v]){
             note[v]=true;
             if(!nxt[v]||find(nxt[v])){
                 nxt[i]=x;
                 return true;
             }
         }
     }
     return false;
}
int solve()
{
    int ans=0;
    for(int i=1;i<=n;i++){
        memset(note,false,sizeof(note));
        if(find(i))
            ans++;
    }
    return ans;
}
int main()
{
    int t,a,b;scanf("%d",&t);
    while (t--){
        memset(head,-1,sizeof(head));
        memset(nxt,0,sizeof(nxt));
        cnt=0;
        scanf("%d",&n);
        m=3*n/2;
        while(m--){
            scanf("%d%d",&a,&b);
            add(a,b);
            add(b,a);
        }
        printf("%d\n",solve()/2);
    }
    return 0;
}
int n,m,t;
struct Edge{
    int to,next;
}edge[maxn*3];
int head[maxn],tot;
void add_edge(int u,int v){
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}
bool vis[maxn];
int nxt[maxn];
int find(int u){
    for(int i=head[u];i!=-1;i=edge[i].next){
        int v=edge[i].to;
        if(!vis[v]){
            vis[v]=1;
            if(nxt[v]==0||find(nxt[v])){
                nxt[v]=u;
                return true;
            }
        }
    }
    return false;
}
int match()
{
    int ans=0;
    for(int i=1;i<=n;i++){
        memset(vis,false,sizeof(vis));
        if(find(i)) ans++;
    }
    return ans;
}
int u,v;
int main()
{
    scanf("%d",&t);
    while (t--){
        scanf("%d",&n);
        memset(head,-1,sizeof(head));
        memset(nxt,0,sizeof(nxt));
        tot=0;
        m=3*n/2;
        while (m--) {
            scanf("%d%d", &u, &v), add_edge(u, v), add_edge(v, u);
        }
        printf("%d\n",match()/2);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值