hdu1700 Points on Cycle (数学)

Problem Description
There is a cycle with its center on the origin.
Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other
you may assume that the radius of the cycle will not exceed 1000.

Input
There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.

Output
For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision
Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X.

NOTE
when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.

Sample Input
  
  
2 1.500 2.000 563.585 1.251

Sample Output
  
  
0.982 -2.299 -2.482 0.299 -280.709 -488.704 -282.876 487.453
#include<stdio.h>
#include<math.h>
int main()
{
    int t;
    double x[3],y[3],c[2],a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&x[0],&y[0]);
        c[0]=x[0]*x[0]+y[0]*y[0];
        if(x[0]==0)
        {
            y[1]=y[2]=-y[0]/2;
            x[1]=-sqrt(c[0]-y[1]*y[1]);
            x[2]=sqrt(c[0]-y[2]*y[2]);
        }
        else
        {
            c[1]=-c[0]+c[0]*c[0]/(4*x[0]*x[0]);
            b=c[0]*y[0]/(x[0]*x[0]);
            a=1+y[0]*y[0]/(x[0]*x[0]);
            y[1]=(-b-sqrt(b*b-4*a*c[1]))/(2*a);
            y[2]=(-b+sqrt(b*b-4*a*c[1]))/(2*a);
            x[1]=-c[0]/(2*x[0])-y[0]*y[1]/x[0];
            x[2]=-c[0]/(2*x[0])-y[0]*y[2]/x[0];
        }
        printf("%.3lf %.3lf %.3lf %.3lf\n",x[1],y[1],x[2],y[2]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值