hdu 3333 Turing Tree (主席树)

Problem Description

After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again…

Now given a sequence of N numbers A1, A2, …, AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, …, Aj.

Input

The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, …, AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

Output

For each Query, print the sum of distinct values of the specified subsequence in one line.

Sample Input

2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5

Sample Output

1
5
6
3
6

题意

给定一串数,每次询问一个区间内不重复的数字之和。多组数据。

题解

考虑使用主席树。不过听说这个题不用这个的数据结构离线线段树就可以做了,但是我不会23333。主席树的新使用方式get,原来不止可以运用到有前缀和性质的题目,就算没有也是可以的。多组数据,开long long 和注意清零。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 30010;

struct Tree {
    int l, r, ls, rs;
    long long sum;
} t[N * 40];

int T, n, m, tot, tail = 0, a[N], b[N], Pre[N], root[N];

int build(int l, int r) {
    int num = ++ tail;
    t[num].l = l, t[num].r = r, t[num].sum = 0;
    if(l == r)
        return num;
    int mid = (l + r) >> 1;
    t[num].ls = build(l, mid);
    t[num].rs = build(mid + 1, r);
    return num;
}

void update(int num) {
    t[num].sum = t[t[num].ls].sum + t[t[num].rs].sum;
}

int modify(int pre, int pos, int delta) {
    int num = ++ tail;
    t[num] = t[pre];
    if(t[num].l == t[num].r) {
        t[num].sum += (long long)delta;
        return num;
    }
    int mid = (t[num].l + t[num].r) >> 1;
    if(pos <= mid)
        t[num].ls = modify(t[pre].ls, pos, delta);
    else
        t[num].rs = modify(t[pre].rs, pos, delta);
    update(num);
    return num;
}

long long query(int num, int L, int R) {
    int l = t[num].l, r = t[num].r;
    if(L <= l && r <= R)
        return t[num].sum;
    long long rt = 0;
    int mid = (l + r) >> 1;
    if(L <= mid)
        rt += query(t[num].ls, L, R);
    if(R > mid)
        rt += query(t[num].rs, L, R);
    return rt;
}

void clear() {
    tail = 0;
    memset(Pre, -1, sizeof(Pre));
}

int main() {
    scanf("%d", &T);
    while(T --) {
        clear();
        scanf("%d", &n);
        for(register int i = 1; i <= n; i ++) {
            scanf("%d", &a[i]);
            b[i] = a[i];
        }
        sort(b + 1, b + n + 1);
        tot = unique(b + 1, b + n + 1) - b - 1;
        root[0] = build(1, n);
        for(int i = 1; i <= n; i ++) {
            int id = lower_bound(b + 1, b + tot + 1, a[i]) - b;
            if(Pre[id] == -1)
                root[i] = modify(root[i - 1], i, a[i]);
            else {
                int t = modify(root[i - 1], Pre[id], -a[i]);
                root[i] = modify(t, i, a[i]);
            }
            Pre[id] = i;
        }
        scanf("%d", &m);
        while(m --) {
            int l, r;
            scanf("%d %d", &l, &r);
            printf("%lld\n", query(root[r], l, r));
        }
    }
    return 0;   
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值