Coin Change
Coin Change |
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and1-cent. We want to make changes with these coins for a given amountof money.
For example, if we have 11 cents, then we can make changeswith one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins.So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of makingchange for zero cent.
Write a program to find the total number ofdifferent ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.
Input
The input file contains any number of lines, each one consisting of a number for the amount of money in cents.Output
For each input line, output a line containing the number of different ways of making changes withthe above 5 types of coins.Sample Input
11 26
Sample Output
4 13
#include<iostream>
using namespace std;
int main()
{
int a,x[5]={1,5,10,25,50};
int n[7500]={0};
n[0]=1;
for(int i=0;i<5;i++)
for(int j=x[i];j<7500;j++)
n[j]+=n[j-x[i]];
while(cin>>a)
cout<<n[a]<<endl;
return 0;
}