hdu 1720 A+B Coming

A+B Coming

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4
Font: Times New Roman | Verdana |Georgia Font Size: ←→

Problem Description

Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^

Input

Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.

Output

Output A+B in decimal number in one line.

Sample Input

1 9
A B
a b

Sample Output

10
21
21

Author

威士忌

Source

HZIEE 2007 Programming Contest
#include <iostream>     
using namespace std;     

int a,b;      

int main()
{      
    while(cin>>hex>>a>>b)     
        cout<<dec<<a+b<<endl;     
    return 0;     
}
 

*有必要总结一下c++输入输出数的进制问题:

dec-十进制(默认)

oct-八进制

hex-十六进制

 


默认没有二进制输出格式。参见:
  %a(%A)     浮点数、十六进制数字和p-(P-)记数法(C99)
  %c          字符  
  %d          有符号十进制整数 
  %f              浮点数(包括float和doulbe)  
  %e(%E)     浮点数指数输出[e-(E-)记数法] 
  %g(%G)     浮点数不显无意义的零"0"  
  %i              有符号十进制整数(与%d相同)  
  %u          无符号十进制整数 
  %o          八进制整数 e.g.     0123  
  %x(%X)      十六进制整数0f(0F) e.g. 0x1234  
  %p          指针  
  %s          字符串  
  %%          "%"


#include <cstdio>
int main()
{  
	int a,b; 
	while(scanf("%x %x",&a,&b)!=EOF)  
		printf("%d\n",a+b);   
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值