hdu 1029 False coin

5 篇文章 0 订阅
2 篇文章 0 订阅

False coin

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.
 

Input
The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting:
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.
 

Output
Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.
 

Sample Input
   
   
5 3 2 1 2 3 4 < 1 1 4 = 1 2 5 =
 

Sample Output
   
   
3
 

Source
PKU
 

#include <stdio.h>
int main()
{
	int num[1001]={0},w[1001]={0},r[1001]={0},n,t,p;
	char sign;
	//num是对硬币编号;w表示重量的比较记录;r存的0,1做标记
	//n为硬币个数;t为称重次数;p为一次每边放硬币个数;sign为比较结果
	int i,tot=0;
	//假硬币每次都会出现,tot用来比较记录重量
	scanf("%d %d",&n,&t);
	while (t--)
	{
		scanf("%d",&p);
		for (i=1;i<=2*p;i++)//读入每次称重的编号
		{
			scanf("%d",&num[i]);			
		}
		//		scanf("%c",&sign);
        getchar();            //吸收回车符
		sign=getchar();
		if (sign=='=')    //左右相等情况
		{
			        //相等时tot不累加
			for (i=1;i<=2*p;i++)
			{
				r[num[i]]=1;           //标记为1为真
			}
		}
		if (sign=='<')   //左边小于右边情况
		{
			tot++;
			for (i=1;i<=p;i++)
			{
				w[num[i]]--;       //重量加减
			}
			for (i=p+1;i<=2*p;i++)
			{
				w[num[i]]++;
			}
		}
		
		if (sign=='>')     //左边大于右边情况
		{
			tot++;
			for (i=1;i<=p;i++)
			{
				w[num[i]]++;
			}
			for (i=p+1;i<=2*p;i++)
			{
				w[num[i]]--;
			}
		}
		
	}
	int count=0,pos=0;
	for (i=1;i<=n;i++)
	{
		if (r[i]!=1)   //count计假硬币个数
		{
			if (w[i]==tot||w[i]==-tot)
			{
				count++;
				pos+=i;
			}
		}
		
	}
	if (count!=1)//只有一个假金币
		printf("0\n");
	else
		printf("%d\n",pos);
	return 0;
}
 
 
 
 
 
错代码
 
 
错误原因:1读入字符没有吸收回车符
                       2控制测量次数的变量i在后面的运行中值发生了改变,并不是按i++累加的
 
#include <stdio.h>
int main()
{
	int str[1005]={0},str1[1005]={0},str2[1005]={0};//数组元素的下标都对应相同
	int n,m,p,i,j,tot=0;//tot赋初值
	int sign;
	scanf("%d%d",&n,&m);
	for (i=0;i<m;i++)//控制测量次数
	{
		scanf("%d",&p);
		for (i=1;i<=2*p;i++)
		{
			scanf("%d",&str2[i]);//输入称重元素!!!
		}
		scanf("%c",&sign);
		if (sign=='=')//相等情况时,对称重元素判定为真
		{
			for (i=1;i<=2*p;i++)
			{
				str[str2[i]]=1;
			}			
		}
		if (sign=='<')
		{
			tot++;
			for (i=1;i<=p;i++)
			{
				str1[str2[i]]--;
			}
			for (j=p+1;j<=2*p;j++)
			{
				str1[str2[j]]++;
			}
		}
		if (sign=='>')
		{
			tot++;
			for (i=1;i<=p;i++)
			{
				str1[str2[i]]++;
			}
			for (j=p+1;j<=2*p;j++)
			{
				str1[str2[j]]--;
			}
		}
	}
	
	int count=0,pos=0;
	for (i=1;i<=n;i++)
	{
		if (str[i]!=1)
		{
			if (str1[i]==tot||str1[i]==-tot)
			{
				count++;
				pos=i;
			}
		}
	}
	if (count!=1)
	{
		printf("0\n");
	}
	else
		printf("%d\n",pos);
	return 0;	
}

 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值