题目1486:False coin

题目描述:

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

输入:

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting:
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

输出:

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

样例输入:
5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=
样例输出:
3


坦率地讲,这道题目最后借鉴了网上的解题思路,代码用自己熟悉的方法书写。

有两种情况需要处理:1.如果式子出现“=”,等式两边的硬币都是真的,用数组标记好。

2.如果式子出现“<”或者“>”,则两边一定有硬币是假的,如果某个硬币一直出现在重的一边或者轻的一边,则该硬币可能是假的。最后统计这样的硬币个 数,如果个数是1,则该硬币是假的,否则无法判定。


#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int lp[1001], rp[1001];
int light[1001], heavy[1001];
bool mark[1001];
int main() {
	int n, k;
	while (cin >> n >> k) {
		memset(light, 0, sizeof(light));
		memset(heavy, 0, sizeof(heavy));
		memset(mark, false, sizeof(mark));
		int cas = 0;
		int p;
		char op;
		for (int i = 1; i <= k; i++) {
			cin >> p;
			for (int j = 1; j <= p; j++)
				cin >> lp[j];
			for (int j = 1; j <= p; j++)
				cin >> rp[j];
			cin >> op;	//这里如果用scanf的话,先要用getchar()将回车换行符吸收掉,防止出错
			if (op == '=') {
				for (int j = 1; j <= p; j++)
					mark[lp[j]] = mark[rp[j]] = true;
			} else if (op == '<') {
				cas++;
				for (int j = 1; j <= p; j++) {
					light[lp[j]]++;
					heavy[rp[j]]++;
				}
			} else {
				cas++;
				for (int j = 1; j <= p; j++) {
					heavy[lp[j]]++;
					light[rp[j]]++;
				}
			}
		}
		int cnt = 0;
		int pos;
		for (int i = 1; i <= n; i++) {
			if (mark[i])
				continue;
			if (heavy[i] == cas || light[i] == cas) {
				cnt++;
				pos = i;
			}
		}
		if (cnt == 1)
			printf("%d\n", pos);
		else
			printf("0\n");
	}
	return 0;
}

题目链接:

http://ac.jobdu.com/problem.php?pid=1486

参考链接:

http://www.cnblogs.com/Norlan/p/5422423.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值