hdu A + B Problem II

5 篇文章 0 订阅
4 篇文章 0 订阅

A + B Problem II

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 1
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 
 
#include <stdio.h>
#include <string.h>
int main()
{
	
	char str1[1005], str2[ 1005];
	int a[1005];
	int i,j, rec, n, len1,len2,T, cas = 1;
	scanf("%d",&T);
	while (T--)
	{

		memset(a,0,sizeof(a));
		scanf("%s%s",str1, str2);
		len1=strlen(str1);//测定字符的长度
		len2=strlen(str2);
		i = len1- 1;
		j = len2 - 1;
		n = 0;
		rec  = 0;
		while(i>=0||j>=0)
		{
			if(i>=0) rec += str1[i--] - '0';//rec随着计算向前移动
			if(j>=0) rec += str2[j--] - '0';
			a[n++] = rec % 10;
			rec = rec/ 10;
		}
		if(rec>0)    a[n++] = rec;
		printf("Case %d:\n",cas++);//case控制行
		printf("%s + %s = ",str1,str2);
		for(i=n-1; i>=0; i--)//输出
		{
			
			printf("%d",a[i]);
		}
			
		if(T==0) printf("\n");//控制格式
		else printf("\n\n");

	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值